summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-20 22:58:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-20 22:58:10 +0000
commit239f1d1861b2e6d79509104d837889285afe6e22 (patch)
treee435537336cc9f7b78b148c0bead486d18059abd /sys-auth
parentVersion bump. (diff)
downloadgentoo-2-239f1d1861b2e6d79509104d837889285afe6e22.tar.gz
gentoo-2-239f1d1861b2e6d79509104d837889285afe6e22.tar.bz2
gentoo-2-239f1d1861b2e6d79509104d837889285afe6e22.zip
Check for kernel option TMPFS_POSIX_ACL with USE="acl" and ensure sys-apps/coreutils is emerged with same wrt #376939 by Arne Stäcker
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/ChangeLog7
-rw-r--r--sys-auth/consolekit/consolekit-0.4.5-r3.ebuild23
2 files changed, 19 insertions, 11 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index 1b798e1b0e6f..76cdfe36b745 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.116 2012/03/20 10:02:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.117 2012/03/20 22:58:10 ssuominen Exp $
+
+ 20 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ consolekit-0.4.5-r3.ebuild:
+ Check for kernel option TMPFS_POSIX_ACL with USE="acl" and ensure
+ sys-apps/coreutils is emerged with same wrt #376939 by Arne Stäcker
20 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
files/consolekit-0.4.5-udev-acl-install_to_usr_and_missing_seat_d_symlink.pat
diff --git a/sys-auth/consolekit/consolekit-0.4.5-r3.ebuild b/sys-auth/consolekit/consolekit-0.4.5-r3.ebuild
index 62ec510b7d72..dbd83c556fd2 100644
--- a/sys-auth/consolekit/consolekit-0.4.5-r3.ebuild
+++ b/sys-auth/consolekit/consolekit-0.4.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.5-r3.ebuild,v 1.1 2012/03/20 07:39:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.5-r3.ebuild,v 1.2 2012/03/20 22:58:10 ssuominen Exp $
EAPI=4
inherit autotools eutils linux-info pam systemd
@@ -21,7 +21,11 @@ RDEPEND=">=dev-libs/dbus-glib-0.98
>=dev-libs/glib-2.22
sys-libs/zlib
x11-libs/libX11
- kernel_linux? ( acl? ( sys-apps/acl >=sys-fs/udev-182 ) )
+ acl? (
+ sys-apps/acl
+ sys-apps/coreutils[acl]
+ >=sys-fs/udev-182
+ )
pam? ( virtual/pam )
policykit? ( >=sys-auth/polkit-0.101-r1 )
!<sys-fs/udev-182"
@@ -34,9 +38,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
pkg_setup() {
- # This is required to get login-session-id string with pam_ck_connector.so
- if use pam && use kernel_linux; then
- CONFIG_CHECK="~AUDITSYSCALL"
+ if use kernel_linux; then
+ # This is from http://bugs.gentoo.org/376939
+ use acl && CONFIG_CHECK="~TMPFS_POSIX_ACL"
+ # This is required to get login-session-id string with pam_ck_connector.so
+ use pam && CONFIG_CHECK+=" ~AUDITSYSCALL"
linux-info_pkg_setup
fi
}
@@ -54,9 +60,6 @@ src_prepare() {
}
src_configure() {
- local myconf
- use kernel_linux && myconf="$(use_enable acl udev-acl)"
-
econf \
XMLTO_FLAGS="--skip-validation" \
--localstatedir="${EPREFIX}"/var \
@@ -64,10 +67,10 @@ src_configure() {
$(use_enable doc docbook-docs) \
$(use_enable debug) \
$(use_enable policykit polkit) \
+ $(use_enable acl udev-acl) \
--with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
--with-pam-module-dir=$(getpam_mod_dir) \
- "$(systemd_with_unitdir)" \
- ${myconf}
+ "$(systemd_with_unitdir)"
}
src_install() {