summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-03-05 23:02:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-03-05 23:02:28 +0000
commit51817473765aa8bc75097cdc197151498de32c87 (patch)
tree741838eb4488fa07ad8ab49835ed581d04c69498 /sys-auth
parentadd a patch by Ryan Hill <dirtyepic@gentoo.org> to fix build with gcc 4.3, bu... (diff)
downloadgentoo-2-51817473765aa8bc75097cdc197151498de32c87.tar.gz
gentoo-2-51817473765aa8bc75097cdc197151498de32c87.tar.bz2
gentoo-2-51817473765aa8bc75097cdc197151498de32c87.zip
New version of pambase with a passwdqc USE flag to enable use of pam_passwdqc.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pambase/ChangeLog8
-rw-r--r--sys-auth/pambase/metadata.xml7
-rw-r--r--sys-auth/pambase/pambase-20080306.ebuild82
3 files changed, 96 insertions, 1 deletions
diff --git a/sys-auth/pambase/ChangeLog b/sys-auth/pambase/ChangeLog
index 19f2b858f2aa..482f48ce7247 100644
--- a/sys-auth/pambase/ChangeLog
+++ b/sys-auth/pambase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pambase
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.16 2008/03/05 17:53:43 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.17 2008/03/05 23:02:28 flameeyes Exp $
+
+*pambase-20080306 (05 Mar 2008)
+
+ 05 Mar 2008; Diego Pettenò <flameeyes@gentoo.org> metadata.xml,
+ +pambase-20080306.ebuild:
+ New version of pambase with a passwdqc USE flag to enable use of pam_passwdqc.
05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> pambase-20080305.ebuild:
Add ~sparc for testing, part of Bug #210770 --- pam still works for me.
diff --git a/sys-auth/pambase/metadata.xml b/sys-auth/pambase/metadata.xml
index 70f1e9b00625..f223bfac8c8f 100644
--- a/sys-auth/pambase/metadata.xml
+++ b/sys-auth/pambase/metadata.xml
@@ -28,5 +28,12 @@
modules supporting this in the system authentication and system
login stacks.
</flag>
+ <flag name="passwdqc">
+ Enable pam_passwdqc module on system auth stack for password
+ quality validation. This is an alternative to pam_cracklib
+ producing warnings, rejecting or providing example passwords
+ when changing your system password. It is used by default by
+ OpenWall GNU/*/Linux and by FreeBSD.
+ </flag>
</use>
</pkgmetadata>
diff --git a/sys-auth/pambase/pambase-20080306.ebuild b/sys-auth/pambase/pambase-20080306.ebuild
new file mode 100644
index 000000000000..12ca91c96139
--- /dev/null
+++ b/sys-auth/pambase/pambase-20080306.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20080306.ebuild,v 1.1 2008/03/05 23:02:28 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="PAM base configuration files"
+SRC_URI="http://www.flameeyes.eu/gentoo-distfiles/${P}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org/proj/en/base/pam/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~hppa ~sparc ~x86"
+IUSE="debug cracklib consolekit gnome selinux"
+
+RDEPEND="
+ || (
+ >=sys-libs/pam-0.99.9.0-r1
+ ( sys-auth/openpam
+ || ( sys-freebsd/freebsd-pam-modules sys-netbsd/netbsd-pam-modules )
+ )
+ )
+ cracklib? ( >=sys-libs/pam-0.99 )
+ consolekit? ( sys-auth/consolekit )
+ gnome? ( >=gnome-base/gnome-keyring-2.20 )
+ selinux? ( >=sys-libs/pam-0.99 )
+ passwdqc? ( >=sys-auth/pam_passwdqc-1.0.4 )
+ !<sys-freebsd/freebsd-pam-modules-6.2-r1
+ !<sys-libs/pam-0.99.9.0-r1"
+DEPEND=""
+
+RESTRICT="binchecks"
+
+pkg_setup() {
+ if use cracklib && ! built_with_use sys-libs/pam cracklib; then
+ eerror "To enable cracklib support in the main PAM configuration"
+ eerror "you need to enable cracklib USE flag on sys-libs/pam"
+ eerror "first."
+ die "Missing pam_cracklib"
+ fi
+
+ if use selinux && ! built_with_use sys-libs/pam selinux; then
+ eerror "To enable selinux support in the main PAM configuration"
+ eerror "you need to enable selinux USE flag on sys-libs/pam"
+ eerror "first."
+ die "Missing pam_selinux"
+ fi
+
+ if use consolekit && ! built_with_use sys-auth/consolekit pam; then
+ eerror "To enable ConsoleKit support in the main PAM configuration"
+ eerror "you need to enable pam USE flag on sys-auth/consolekit"
+ eerror "first."
+ die "Missing pam_ck_connector"
+ fi
+
+ if use gnome && ! built_with_use gnome-base/gnome-keyring pam; then
+ eerror "To enable GNOME Keyring support in the main PAM configuration"
+ eerror "you need to enable pam USE flag on gnome-base/gnome-keyring"
+ eerror "first."
+ die "Missing pam_gnome_keyring"
+ fi
+}
+
+src_compile() {
+ has_version sys-libs/pam && implementation="linux-pam"
+ has_version sys-auth/openpam && implementation="openpam"
+
+ emake \
+ GIT=true \
+ DEBUG=$(use debug && echo yes || echo no) \
+ CRACKLIB=$(use cracklib && echo yes || echo no) \
+ PASSWDQC=$(use passwdqc && echo yes || echo no) \
+ CONSOLEKIT=$(use consolekit && echo yes || echo no) \
+ GNOME_KEYRING=$(use gnome && echo yes || echo no) \
+ SELINUX=$(use selinux && echo yes || echo no) \
+ IMPLEMENTATION=${implementation} \
+ || die "emake failed"
+}
+
+src_install() {
+ emake GIT=true DESTDIR="${D}" install || die "emake install failed"
+}