summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-10-11 22:07:23 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-10-11 22:07:23 +0000
commit85a4ba25f94ac5ee73c936d348ec7bb233619c2b (patch)
treeb072ad84a9cd99ba9e0dbfe79c0e0ec0044ec6c6 /sys-auth
parentBump Debian patchset for new Dell server support, also add optional static bu... (diff)
downloadgentoo-2-85a4ba25f94ac5ee73c936d348ec7bb233619c2b.tar.gz
gentoo-2-85a4ba25f94ac5ee73c936d348ec7bb233619c2b.tar.bz2
gentoo-2-85a4ba25f94ac5ee73c936d348ec7bb233619c2b.zip
bup
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog9
-rw-r--r--sys-auth/keystone/keystone-2014.1.3.ebuild (renamed from sys-auth/keystone/keystone-2014.1.2.1.ebuild)9
-rw-r--r--sys-auth/keystone/keystone-2014.1.9999.ebuild8
3 files changed, 18 insertions, 8 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 306ffd85cbee..34beb54bd00f 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.79 2014/08/19 02:41:45 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.80 2014/10/11 22:07:23 prometheanfire Exp $
+
+*keystone-2014.1.3 (11 Oct 2014)
+
+ 11 Oct 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +keystone-2014.1.3.ebuild, -keystone-2014.1.2.1.ebuild,
+ keystone-2014.1.9999.ebuild:
+ bup
19 Aug 2014; Matthew Thode <prometheanfire@gentoo.org>
-keystone-2014.1.1-r2.ebuild:
diff --git a/sys-auth/keystone/keystone-2014.1.2.1.ebuild b/sys-auth/keystone/keystone-2014.1.3.ebuild
index 7739994faf3e..8ef2f229f187 100644
--- a/sys-auth/keystone/keystone-2014.1.2.1.ebuild
+++ b/sys-auth/keystone/keystone-2014.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.2.1.ebuild,v 1.1 2014/08/19 02:39:33 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.3.ebuild,v 1.1 2014/10/11 22:07:23 prometheanfire Exp $
EAPI=5
@@ -11,7 +11,7 @@ inherit distutils-r1 user
DESCRIPTION="The Openstack authentication, authorization, and service catalog written in Python"
HOMEPAGE="https://launchpad.net/keystone"
#SRC_URI="http://launchpad.net/${PN}/icehouse/${PV}/+download/${P}.tar.gz"
-SRC_URI="http://launchpad.net/${PN}/icehouse/2014.1.2/+download/${P}.tar.gz"
+SRC_URI="http://launchpad.net/${PN}/icehouse/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -20,7 +20,6 @@ IUSE="+sqlite mysql postgres ldap test"
REQUIRED_USE="|| ( mysql postgres sqlite )"
#todo, seperate out rdepend via use flags
-# python-ldap needs to be relaxed...
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-0.6[${PYTHON_USEDEP}]
<dev-python/pbr-1.0[${PYTHON_USEDEP}]
@@ -36,7 +35,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
>=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.1.9999[${PYTHON_USEDEP}]
>=dev-python/webtest-2.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
@@ -57,6 +56,7 @@ RDEPEND=">=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ !~dev-python/routes-2.0[${PYTHON_USEDEP}]
>=dev-python/six-1.6.0[${PYTHON_USEDEP}]
sqlite? (
>=dev-python/sqlalchemy-0.8.0[sqlite,${PYTHON_USEDEP}]
@@ -76,6 +76,7 @@ RDEPEND=">=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
<=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
)
>=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-migrate-0.9.2[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-2014.1.9999.ebuild b/sys-auth/keystone/keystone-2014.1.9999.ebuild
index d500b879b2b7..57da3165d427 100644
--- a/sys-auth/keystone/keystone-2014.1.9999.ebuild
+++ b/sys-auth/keystone/keystone-2014.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.9999.ebuild,v 1.5 2014/08/10 20:21:57 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.9999.ebuild,v 1.6 2014/10/11 22:07:23 prometheanfire Exp $
EAPI=5
@@ -29,13 +29,13 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-lang/python[sqlite]
>=dev-python/python-memcached-1.48[${PYTHON_USEDEP}]
>=dev-python/pymongo-2.4[${PYTHON_USEDEP}]
- ldap? ( ~dev-python/python-ldap-2.3.13 )
+ ldap? ( dev-python/python-ldap )
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
>=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
>=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.1.9999[${PYTHON_USEDEP}]
>=dev-python/webtest-2.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
@@ -56,6 +56,7 @@ RDEPEND=">=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ !~dev-python/routes-2.0[${PYTHON_USEDEP}]
>=dev-python/six-1.6.0[${PYTHON_USEDEP}]
sqlite? (
>=dev-python/sqlalchemy-0.8.0[sqlite,${PYTHON_USEDEP}]
@@ -75,6 +76,7 @@ RDEPEND=">=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
<=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
)
>=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-migrate-0.9.2[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]