summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-13 15:12:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-13 15:12:52 +0000
commitef43fc7a989bb7c7e06a783343dd727579f74f8d (patch)
tree39e25995ba0bddd6760c16063e34a5eebd3f790d /sys-auth
parentx86 stable wrt bug #313903 (diff)
downloadgentoo-2-ef43fc7a989bb7c7e06a783343dd727579f74f8d.tar.gz
gentoo-2-ef43fc7a989bb7c7e06a783343dd727579f74f8d.tar.bz2
gentoo-2-ef43fc7a989bb7c7e06a783343dd727579f74f8d.zip
Fix build on fbsd and keyword it x86-fbsd
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog6
-rw-r--r--sys-auth/polkit/files/polkit-0.96-getcwd.patch22
-rw-r--r--sys-auth/polkit/polkit-0.96-r1.ebuild5
3 files changed, 30 insertions, 3 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index bf8b48bcd675..f6deffc9bc28 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.13 2010/03/25 14:50:22 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.14 2010/04/13 15:12:52 aballier Exp $
+
+ 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
+ +files/polkit-0.96-getcwd.patch:
+ Fix build on fbsd and keyword it x86-fbsd
25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
polkit-0.96-r1.ebuild:
diff --git a/sys-auth/polkit/files/polkit-0.96-getcwd.patch b/sys-auth/polkit/files/polkit-0.96-getcwd.patch
new file mode 100644
index 000000000000..cca8a2bd10f2
--- /dev/null
+++ b/sys-auth/polkit/files/polkit-0.96-getcwd.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/show_bug.cgi?id=309457
+https://bugs.freedesktop.org/show_bug.cgi?id=27081
+
+--- src/programs/pkexec.c.old 2010-03-15 08:49:30.000000000 +0100
++++ src/programs/pkexec.c 2010-03-15 08:54:16.000000000 +0100
+@@ -375,6 +375,7 @@
+ gchar *path;
+ struct passwd pwstruct;
+ gchar pwbuf[8192];
++ gchar cwdbuf[PATH_MAX];
+ gchar *s;
+ const gchar *environment_variables_to_save[] = {
+ "SHELL",
+@@ -438,7 +439,7 @@
+ goto out;
+ }
+
+- original_cwd = g_strdup (get_current_dir_name ());
++ original_cwd = g_strdup (getcwd(cwdbuf,PATH_MAX));
+ if (original_cwd == NULL)
+ {
+ g_printerr ("Error getting cwd.\n");
diff --git a/sys-auth/polkit/polkit-0.96-r1.ebuild b/sys-auth/polkit/polkit-0.96-r1.ebuild
index 3c755083e4d5..ddbf42aa1ffb 100644
--- a/sys-auth/polkit/polkit-0.96-r1.ebuild
+++ b/sys-auth/polkit/polkit-0.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.96-r1.ebuild,v 1.2 2010/03/25 14:50:22 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.96-r1.ebuild,v 1.3 2010/04/13 15:12:52 aballier Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc examples expat nls pam"
# introspection
@@ -40,6 +40,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${P}-getcwd.patch"
if ! use pam; then
# Experimental shadow support, bug 291116
epatch "${WORKDIR}/${P}-r1-shadow-support.patch"