summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-05-24 10:41:58 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-05-24 10:41:58 +0000
commite146a5c36c419aa08a3416686e80fc87e0d2c00d (patch)
treedc7c3550204a10d69870f28fa90a2685f5b58175 /sys-block/afacli/afacli-4.1.ebuild
parentold (diff)
downloadgentoo-2-e146a5c36c419aa08a3416686e80fc87e0d2c00d.tar.gz
gentoo-2-e146a5c36c419aa08a3416686e80fc87e0d2c00d.tar.bz2
gentoo-2-e146a5c36c419aa08a3416686e80fc87e0d2c00d.zip
initial import
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'sys-block/afacli/afacli-4.1.ebuild')
-rw-r--r--sys-block/afacli/afacli-4.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-block/afacli/afacli-4.1.ebuild b/sys-block/afacli/afacli-4.1.ebuild
new file mode 100644
index 000000000000..eb16390b8435
--- /dev/null
+++ b/sys-block/afacli/afacli-4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/afacli/afacli-4.1.ebuild,v 1.1 2008/05/24 10:41:57 wschlich Exp $
+
+inherit rpm
+
+MY_PV=${PV}-0
+DESCRIPTION="Dell AACRAID-based PERC RAID controller management tool"
+HOMEPAGE="http://linux.dell.com/"
+SRC_URI="ftp://ftp.dell.com/scsi-raid/afa-apps-snmp.2807420-A04.tar.gz"
+
+LICENSE="Dell"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~x86"
+IUSE=""
+
+RESTRICT="strip mirror test"
+
+RDEPEND="sys-libs/lib-compat"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ rpm_unpack "${S}"/afaapps-${MY_PV}.i386.rpm || die "failed to unpack RPM"
+}
+
+src_compile() {
+ echo "Nothing to compile."
+}
+
+src_install() {
+ dosbin "${FILESDIR}"/afacli
+ newsbin usr/sbin/afacli afacli.bin
+ dodoc usr/sbin/getcfg.afa
+}