summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-28 16:05:56 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-28 16:05:56 +0000
commit4eaffafdd5dcec27cc908047507b919eedb7515d (patch)
treea503106abc507e1b3d1cc6e824d676a4a1a9993d /sys-boot/elilo
parentRemoving package. (diff)
downloadgentoo-2-4eaffafdd5dcec27cc908047507b919eedb7515d.tar.gz
gentoo-2-4eaffafdd5dcec27cc908047507b919eedb7515d.tar.bz2
gentoo-2-4eaffafdd5dcec27cc908047507b919eedb7515d.zip
use tc-getCC
Diffstat (limited to 'sys-boot/elilo')
-rw-r--r--sys-boot/elilo/elilo-3.4.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-boot/elilo/elilo-3.4.ebuild b/sys-boot/elilo/elilo-3.4.ebuild
index e313e25fc606..8014a65d45c6 100644
--- a/sys-boot/elilo/elilo-3.4.ebuild
+++ b/sys-boot/elilo/elilo-3.4.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4.ebuild,v 1.6 2004/06/24 22:34:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4.ebuild,v 1.7 2004/10/28 16:04:50 vapier Exp $
inherit eutils
DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
HOMEPAGE="http://developer.intel.com/technology/efi"
SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/${P}.tar.gz"
-KEYWORDS="ia64"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64"
IUSE=""
# gnu-efi contains only static libs, so there's no run-time dep on it
@@ -18,9 +19,10 @@ RDEPEND="sys-boot/efibootmgr
sys-fs/dosfstools"
src_unpack() {
- unpack ${A} && cd ${S} || die "failed to unpack"
- epatch ${FILESDIR}/elilo-3.4-makefile.patch || die "epatch failed"
- epatch ${FILESDIR}/elilo-3.3a-devscheme.patch || die "epatch failed"
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/elilo-3.4-makefile.patch
+ epatch ${FILESDIR}/elilo-3.3a-devscheme.patch
}
src_compile() {
@@ -34,7 +36,7 @@ src_compile() {
# "prefix" on the next line specifies where to find gcc, as, ld,
# etc. It's not the usual meaning of "prefix". By blanking it we
# allow PATH to be searched.
- emake -j1 prefix= CC="${CC}" ARCH=${iarch} || die "emake failed"
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
# unversion the man-pages and Debian's elilo script
cp ${FILESDIR}/elilo.8-${PV} elilo.8
@@ -43,9 +45,7 @@ src_compile() {
}
src_install() {
- dodir /usr/lib/elilo || die
- dodir /usr/sbin || die
- dodir /etc || die
+ dodir /usr/lib/elilo /usr/sbin /etc
# install the efi executable in a known location
install -m755 elilo.efi ${D}/usr/lib/elilo || die