summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-09 23:07:13 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-09 23:07:13 +0000
commit4f089fbccb5100b1a2f079d58ee5ac7e5cb04d47 (patch)
tree009c54ba120a4a3a1925b0124fe1aad72bdc4415 /sys-boot/grub
parentVersion bump, security bug #489570. (diff)
downloadgentoo-2-4f089fbccb5100b1a2f079d58ee5ac7e5cb04d47.tar.gz
gentoo-2-4f089fbccb5100b1a2f079d58ee5ac7e5cb04d47.tar.bz2
gentoo-2-4f089fbccb5100b1a2f079d58ee5ac7e5cb04d47.zip
Adjust *FLAGS logic and drop custom-cflags use flag.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog5
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index f3299060b15a..e91d5eb10ca7 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.294 2013/12/09 22:10:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.295 2013/12/09 23:07:13 floppym Exp $
+
+ 09 Dec 2013; Mike Gilbert <floppym@gentoo.org> grub-9999-r1.ebuild:
+ Adjust *FLAGS logic and drop custom-cflags use flag.
09 Dec 2013; Mike Gilbert <floppym@gentoo.org> grub-9999-r1.ebuild:
Re-enable python3.
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index ccd6454cf950..9f15b60855c6 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.5 2013/12/09 22:10:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.6 2013/12/09 23:07:13 floppym Exp $
EAPI=5
@@ -48,7 +48,7 @@ HOMEPAGE="http://www.gnu.org/software/grub/"
# Includes licenses for dejavu and unifont
LICENSE="GPL-3 truetype? ( BitstreamVera GPL-2-with-font-exception )"
SLOT="2"
-IUSE="custom-cflags debug device-mapper doc efiemu mount +multislot nls static sdl test truetype libzfs"
+IUSE="debug device-mapper doc efiemu mount +multislot nls static sdl test truetype libzfs"
GRUB_ALL_PLATFORMS=(
# everywhere:
@@ -228,8 +228,14 @@ grub_configure() {
}
src_configure() {
- use custom-cflags || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
- use static && export HOST_LDFLAGS="${HOST_LDFLAGS} -static"
+ # We don't want to leak flags onto boot code.
+ export HOST_CCASFLAGS=${CCASFLAGS}
+ export HOST_CFLAGS=${CFLAGS}
+ export HOST_CPPFLAGS=${CPPFLAGS}
+ export HOST_LDFLAGS=${LDFLAGS}
+ unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
+
+ use static && HOST_LDFLAGS+=" -static"
if version_is_at_least 4.8 "$(gcc-version)"; then
export TARGET_LDFLAGS+=" -fuse-ld=bfd"