summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-03-31 17:04:36 +0000
committerMike Gilbert <floppym@gentoo.org>2013-03-31 17:04:36 +0000
commitd8675c57dfe935146f8f6ef997a124a7dc16930c (patch)
treeb40b05c3dd9fc9f555986c11d3e3dd45387f0645 /sys-boot/grub
parentStable for x86, wrt bug #462890 (diff)
downloadgentoo-2-d8675c57dfe935146f8f6ef997a124a7dc16930c.tar.gz
gentoo-2-d8675c57dfe935146f8f6ef997a124a7dc16930c.tar.bz2
gentoo-2-d8675c57dfe935146f8f6ef997a124a7dc16930c.zip
Fix detection of genkernel initramfs on xen.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/files/grub-2.00-20_linux_xen.patch14
-rw-r--r--sys-boot/grub/grub-2.00-r2.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index a40edf7c3f73..7e14107d6ee3 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.252 2013/02/05 17:14:03 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.253 2013/03/31 17:04:36 floppym Exp $
+
+ 31 Mar 2013; Mike Gilbert <floppym@gentoo.org>
+ +files/grub-2.00-20_linux_xen.patch, grub-2.00-r2.ebuild:
+ Fix detection of genkernel initramfs on xen.
05 Feb 2013; Mike Gilbert <floppym@gentoo.org> grub-2.00-r2.ebuild,
grub-9999.ebuild:
diff --git a/sys-boot/grub/files/grub-2.00-20_linux_xen.patch b/sys-boot/grub/files/grub-2.00-20_linux_xen.patch
new file mode 100644
index 000000000000..c83f0b04aaa3
--- /dev/null
+++ b/sys-boot/grub/files/grub-2.00-20_linux_xen.patch
@@ -0,0 +1,14 @@
+Fix detection of genkernel initramfs for xen
+
+https://bugs.gentoo.org/show_bug.cgi?id=463992
+
+--- a/util/grub.d/20_linux_xen.in
++++ b/util/grub.d/20_linux_xen.in
+@@ -174,6 +174,7 @@
+
+ title_correction_code=
+
++machine=`uname -m`
+ case "$machine" in
+ i?86) GENKERNEL_ARCH="x86" ;;
+ mips|mips64) GENKERNEL_ARCH="mips" ;;
diff --git a/sys-boot/grub/grub-2.00-r2.ebuild b/sys-boot/grub/grub-2.00-r2.ebuild
index 290738662b07..df7b9fbbc5e3 100644
--- a/sys-boot/grub/grub-2.00-r2.ebuild
+++ b/sys-boot/grub/grub-2.00-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00-r2.ebuild,v 1.5 2013/02/18 16:45:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00-r2.ebuild,v 1.6 2013/03/31 17:04:36 floppym Exp $
EAPI=4
@@ -241,6 +241,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-freebsd.patch" #442050
epatch "${FILESDIR}/${P}-compression.patch" #424527
epatch "${FILESDIR}/${P}-zfs-feature-flag-support.patch" #455358
+ epatch "${FILESDIR}/${P}-20_linux_xen.patch" #463992
fi
# fix texinfo file name, bug 416035