summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-03-08 05:06:32 +0000
committerJeroen Roovers <jer@gentoo.org>2010-03-08 05:06:32 +0000
commit72ae1a1266c9ae54a2cb8b5b2d31e602365829d8 (patch)
tree1e4df331668005c69e088b5af48dad4d8039a49c /sys-boot/palo
parentnote another test-related bug (diff)
downloadgentoo-2-72ae1a1266c9ae54a2cb8b5b2d31e602365829d8.tar.gz
gentoo-2-72ae1a1266c9ae54a2cb8b5b2d31e602365829d8.tar.bz2
gentoo-2-72ae1a1266c9ae54a2cb8b5b2d31e602365829d8.zip
Version bump with only trivial changes, but with an extra patch to build with -D_FORTIFY_SOURCE=2.
(Portage version: 2.2_rc65/cvs/Linux i686)
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/ChangeLog11
-rw-r--r--sys-boot/palo/files/palo-1.17-fortify-source.patch15
-rw-r--r--sys-boot/palo/palo-1.17.ebuild48
3 files changed, 72 insertions, 2 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index 70762b174c5b..0de8b796b33e 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/palo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.23 2009/08/14 14:02:37 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.24 2010/03/08 05:06:30 jer Exp $
+
+*palo-1.17 (08 Mar 2010)
+
+ 08 Mar 2010; Jeroen Roovers <jer@gentoo.org> +palo-1.17.ebuild,
+ +files/palo-1.17-fortify-source.patch:
+ Version bump with only trivial changes, but with an extra patch to build
+ with -D_FORTIFY_SOURCE=2.
14 Aug 2009; Jeroen Roovers <jer@gentoo.org> -palo-1.2_pre20030630.ebuild,
-palo-1.3_pre20040303.ebuild, -palo-1.5_pre20040515.ebuild,
diff --git a/sys-boot/palo/files/palo-1.17-fortify-source.patch b/sys-boot/palo/files/palo-1.17-fortify-source.patch
new file mode 100644
index 000000000000..6a6adcdafdca
--- /dev/null
+++ b/sys-boot/palo/files/palo-1.17-fortify-source.patch
@@ -0,0 +1,15 @@
+ * palo/palo.c: Supply a mode to open() to go with the O_CREAT flag.
+
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506083
+
+--- a/palo/palo.c
++++ b/palo/palo.c
+@@ -479,7 +479,7 @@
+ error(14, "bootloader");
+
+ sprintf(badblockfilename, "/tmp/paloblk-%d", getpid());
+- if ((fd = open(badblockfilename, O_RDWR | O_CREAT | O_TRUNC)) < 0) {
++ if ((fd = open(badblockfilename, O_RDWR | O_CREAT | O_TRUNC, 0644)) < 0) {
+ perror(badblockfilename);
+ exit(1);
+ }
diff --git a/sys-boot/palo/palo-1.17.ebuild b/sys-boot/palo/palo-1.17.ebuild
new file mode 100644
index 000000000000..2a777ae2433b
--- /dev/null
+++ b/sys-boot/palo/palo-1.17.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.17.ebuild,v 1.1 2010/03/08 05:06:30 jer Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+DEPEND=""
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${PN}-remove-HOME-TERM.patch \
+ "${FILESDIR}"/${PN}-1.16_p1-build.patch \
+ "${FILESDIR}"/${PN}-1.17-fortify-source.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake -C palo || die "make palo failed"
+ emake -C ipl || die "make ipl failed"
+ emake MACHINE=parisc iplboot || die "make iplboot failed"
+}
+
+src_install() {
+ into /
+ dosbin palo/palo || die
+
+ doman palo.8
+ dohtml README.html
+ dodoc README palo.conf
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf || die
+
+ insinto /usr/share/palo
+ doins iplboot || die
+}