summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-21 20:47:00 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-21 20:47:00 +0000
commit825e4e4219d8d4332216f642d132ee239568636a (patch)
treee9c0ba0d4d2ada3ae6c88142960555007fa13648 /sys-boot/palo
parentVersion bump (diff)
downloadgentoo-2-825e4e4219d8d4332216f642d132ee239568636a.tar.gz
gentoo-2-825e4e4219d8d4332216f642d132ee239568636a.tar.bz2
gentoo-2-825e4e4219d8d4332216f642d132ee239568636a.zip
Add missing include. Bump version that upstream non-maintainer commit missed. Respect LDFLAGS.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/ChangeLog9
-rw-r--r--sys-boot/palo/files/palo-1.18-include.patch12
-rw-r--r--sys-boot/palo/palo-1.18-r1.ebuild47
3 files changed, 67 insertions, 1 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index afa9337286c6..55d2e5623158 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/palo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.30 2011/04/05 15:52:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.31 2011/04/21 20:47:00 jer Exp $
+
+*palo-1.18-r1 (21 Apr 2011)
+
+ 21 Apr 2011; Jeroen Roovers <jer@gentoo.org> +palo-1.18-r1.ebuild,
+ +files/palo-1.18-include.patch:
+ Add missing include. Bump version that upstream non-maintainer commit missed.
+ Respect LDFLAGS.
05 Apr 2011; Jeroen Roovers <jer@gentoo.org> palo-1.18.ebuild:
Remove virtual/bootloader (bug #359971).
diff --git a/sys-boot/palo/files/palo-1.18-include.patch b/sys-boot/palo/files/palo-1.18-include.patch
new file mode 100644
index 000000000000..47f9c0e087ce
--- /dev/null
+++ b/sys-boot/palo/files/palo-1.18-include.patch
@@ -0,0 +1,12 @@
+paloio.c:64: warning: implicit declaration of function ‘memcmp’
+
+--- a/palo/paloio.c 2007-09-12 18:12:03.000000000 +0200
++++ b/palo/paloio.c 2011-04-21 22:35:10.000000000 +0200
+@@ -7,6 +7,7 @@
+ */
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/sys-boot/palo/palo-1.18-r1.ebuild b/sys-boot/palo/palo-1.18-r1.ebuild
new file mode 100644
index 000000000000..8c39be9d6ee6
--- /dev/null
+++ b/sys-boot/palo/palo-1.18-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.18-r1.ebuild,v 1.1 2011/04/21 20:47:00 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ http://packages.qa.debian.org/p/palo.html"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-remove-HOME-TERM.patch \
+ "${FILESDIR}"/${PN}-1.16_p1-build.patch \
+ "${FILESDIR}"/${P}-include.patch
+ sed -i lib/common.h -e '/^#define PALOVERSION/{s|".*"|"'${PV}'"|g}' || die
+ sed -i palo/Makefile -e '/^LDFLAGS=/d' || die
+}
+
+src_compile() {
+ tc-export CC
+ emake -C palo || die "make palo failed"
+ emake -C ipl || die "make ipl failed"
+ emake MACHINE=parisc iplboot || die "make iplboot failed"
+}
+
+src_install() {
+ into /
+ dosbin palo/palo || die
+
+ doman palo.8
+ dohtml README.html
+ dodoc README palo.conf
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf || die
+
+ insinto /usr/share/palo
+ doins iplboot || die
+}