summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-09-06 21:18:04 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-09-06 21:18:04 +0000
commit9e0e5744216e70ca6291c71ebef16110e785cb09 (patch)
treef58c5f7c051e7b4992ba83c499aad7267679832d /sys-boot/yaboot/yaboot-1.3.14.ebuild
parentMarked ppc/ppc64 stable for bug #191417. (diff)
downloadgentoo-2-9e0e5744216e70ca6291c71ebef16110e785cb09.tar.gz
gentoo-2-9e0e5744216e70ca6291c71ebef16110e785cb09.tar.bz2
gentoo-2-9e0e5744216e70ca6291c71ebef16110e785cb09.zip
Added latest version. Removed old versions and obsolete patches. Fixed nopiessp patch.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-boot/yaboot/yaboot-1.3.14.ebuild')
-rw-r--r--sys-boot/yaboot/yaboot-1.3.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/yaboot/yaboot-1.3.14.ebuild b/sys-boot/yaboot/yaboot-1.3.14.ebuild
new file mode 100644
index 000000000000..70217e6f7eb9
--- /dev/null
+++ b/sys-boot/yaboot/yaboot-1.3.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14.ebuild,v 1.1 2007/09/06 21:18:04 josejx Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="PPC Bootloader"
+SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
+HOMEPAGE="http://yaboot.ozlabs.org"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~ppc -ppc64"
+IUSE="ibm"
+
+DEPEND="sys-apps/powerpc-utils"
+RDEPEND="!ibm? ( sys-fs/hfsutils )
+ !ibm? ( sys-fs/hfsplusutils )"
+
+PROVIDE="virtual/bootloader"
+
+src_compile() {
+ export -n CFLAGS
+ export -n CXXFLAGS
+ [ -n "$(tc-getCC)" ] || CC="gcc"
+ # dual boot patch
+ epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
+ epatch "${FILESDIR}/chrpfix.patch"
+ epatch "${FILESDIR}/yaboot-nopiessp.patch"
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ cp etc/yaboot.conf etc/yaboot.conf.bak
+ sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
+ mv -f etc/yaboot.conf.edit etc/yaboot.conf
+ make ROOT=${D} PREFIX=/usr MANDIR=share/man install || die
+}