summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-17 04:16:27 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-17 04:16:27 +0000
commit8459687b0f2f3427c3a2194bf2a2cdb8a72b63fe (patch)
treead38fddbd12f900f82839dae128a0703afd0c4f8 /sys-boot/yaboot
parentRemove legacy CC setup -- always use tc-getCC. Also make sure we respect LD. (diff)
downloadgentoo-2-8459687b0f2f3427c3a2194bf2a2cdb8a72b63fe.tar.gz
gentoo-2-8459687b0f2f3427c3a2194bf2a2cdb8a72b63fe.tar.bz2
gentoo-2-8459687b0f2f3427c3a2194bf2a2cdb8a72b63fe.zip
Drop hardcoded -I/usr/include which breaks cross-compiles and is not needed for native builds.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot/yaboot')
-rw-r--r--sys-boot/yaboot/ChangeLog7
-rw-r--r--sys-boot/yaboot/yaboot-1.3.14-r2.ebuild8
-rw-r--r--sys-boot/yaboot/yaboot-1.3.16.ebuild7
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r2.ebuild7
4 files changed, 25 insertions, 4 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index dd0fe91ecedd..5567ddf20102 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/yaboot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.46 2015/05/17 04:12:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.47 2015/05/17 04:16:27 vapier Exp $
+
+ 17 May 2015; Mike Frysinger <vapier@gentoo.org> yaboot-1.3.14-r2.ebuild,
+ yaboot-1.3.16.ebuild, yaboot-1.3.17-r2.ebuild:
+ Drop hardcoded -I/usr/include which breaks cross-compiles and is not needed
+ for native builds.
17 May 2015; Mike Frysinger <vapier@gentoo.org> yaboot-1.3.14-r2.ebuild,
yaboot-1.3.16.ebuild, yaboot-1.3.17-r2.ebuild:
diff --git a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
index ddcf700c3c48..ee939a275d38 100644
--- a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.6 2015/05/17 04:12:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.7 2015/05/17 04:16:27 vapier Exp $
inherit eutils toolchain-funcs
@@ -19,6 +19,12 @@ RDEPEND="!ibm? ( sys-fs/hfsutils
src_compile() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
+
+ # No need to hardcode this path -- the compiler already knows to use it.
+ sed -i \
+ -e 's:-I/usr/include::' \
+ Makefile || die
+
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"
diff --git a/sys-boot/yaboot/yaboot-1.3.16.ebuild b/sys-boot/yaboot/yaboot-1.3.16.ebuild
index c53dada7f2e4..6773c75114ab 100644
--- a/sys-boot/yaboot/yaboot-1.3.16.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.7 2015/05/17 04:12:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.8 2015/05/17 04:16:27 vapier Exp $
inherit eutils toolchain-funcs
@@ -22,6 +22,11 @@ src_unpack() {
cd "${S}"
cp "${FILESDIR}/new-ofpath" "${S}/ybin/ofpath"
+ # No need to hardcode this path -- the compiler already knows to use it.
+ sed -i \
+ -e 's:-I/usr/include::' \
+ Makefile || die
+
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
index 9fb9e07f27ba..2e4d576f921e 100644
--- a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.4 2015/05/17 04:12:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.5 2015/05/17 04:16:27 vapier Exp $
EAPI=2
@@ -27,6 +27,11 @@ src_unpack() {
}
src_prepare() {
+ # No need to hardcode this path -- the compiler already knows to use it.
+ sed -i \
+ -e 's:-I/usr/include::' \
+ Makefile || die
+
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"