summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-07-13 11:47:04 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-07-13 11:47:04 +0000
commit1c7119719583810a5d760fb006c46497c192fb09 (patch)
treea71d4ee90c65940ce8e5eb3850d7f4a23a0490fc /sys-boot
parentEbuild cleanup. (diff)
downloadgentoo-2-1c7119719583810a5d760fb006c46497c192fb09.tar.gz
gentoo-2-1c7119719583810a5d760fb006c46497c192fb09.tar.bz2
gentoo-2-1c7119719583810a5d760fb006c46497c192fb09.zip
Portage may whine about LILO prestripping the chainloader but does not do this properly by itself, as pointed out by Ulrich Mueller <ulm@kph.uni-mainz.de> in bug #140210. People will have to live with the QA warning for now.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/ChangeLog12
-rw-r--r--sys-boot/lilo/files/digest-lilo-22.7.2-r16
-rw-r--r--sys-boot/lilo/lilo-22.7.2-r1.ebuild193
3 files changed, 210 insertions, 1 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index 01d31602d4f7..d14261efe311 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-boot/lilo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.38 2006/07/12 13:49:07 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.39 2006/07/13 11:47:04 chainsaw Exp $
+
+*lilo-22.7.2-r1 (13 Jul 2006)
+
+ 13 Jul 2006; Tony Vroon <chainsaw@gentoo.org>
+ -files/lilo-22.7.2-nostrip.patch, -lilo-22.7.2.ebuild,
+ +lilo-22.7.2-r1.ebuild:
+ Portage may whine about LILO prestripping the chainloader but does not do
+ this properly by itself, as pointed out by Ulrich Mueller
+ <ulm@kph.uni-mainz.de> in bug #140210. People will have to live with the QA
+ warning for now.
*lilo-22.7.2 (12 Jul 2006)
diff --git a/sys-boot/lilo/files/digest-lilo-22.7.2-r1 b/sys-boot/lilo/files/digest-lilo-22.7.2-r1
new file mode 100644
index 000000000000..84ae9e925068
--- /dev/null
+++ b/sys-boot/lilo/files/digest-lilo-22.7.2-r1
@@ -0,0 +1,6 @@
+MD5 88acd6cac12da7e6da02615ba1ca6ddf dolilo-0.3.tar.bz2 3554
+RMD160 b9ae32021767b3548d6fdfe6b71d9100d81ed2ba dolilo-0.3.tar.bz2 3554
+SHA256 33ecd4f54f06067e937f442d1fd7b219f82dbcb7934311d3d20fe070cc2a30ed dolilo-0.3.tar.bz2 3554
+MD5 2bf1eb08c449a28ebadcf66c48a26567 lilo-22.7.2.src.tar.gz 433625
+RMD160 03fe32839751b3497dc9f06490dc2cd3bff6b805 lilo-22.7.2.src.tar.gz 433625
+SHA256 3fae019ee67a63f8fc35aade5e7f61a1dd01a210af1b46c6df4b9862597547da lilo-22.7.2.src.tar.gz 433625
diff --git a/sys-boot/lilo/lilo-22.7.2-r1.ebuild b/sys-boot/lilo/lilo-22.7.2-r1.ebuild
new file mode 100644
index 000000000000..2274c6107fd8
--- /dev/null
+++ b/sys-boot/lilo/lilo-22.7.2-r1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.2-r1.ebuild,v 1.1 2006/07/13 11:47:04 chainsaw Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOLILO_V="0.3"
+IUSE="devmap static minimal pxeserial"
+
+DESCRIPTION="Standard Linux boot loader"
+HOMEPAGE="http://lilo.go.dyndns.org/pub/linux/lilo/"
+DOLILO_TAR="dolilo-${DOLILO_V}.tar.bz2"
+MY_P=${P}.src
+
+SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${MY_P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${MY_P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${MY_P}.tar.gz
+ mirror://gentoo/${DOLILO_TAR}"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~x86 ~amd64"
+
+RDEPEND="devmap? ( >=sys-fs/device-mapper-1.00.08 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/bin86-0.15.5"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ einfo "If you want to use lilo with device mapper, please enable the"
+ einfo "\"devmap\" USE flag."
+
+ unpack ${MY_P}.tar.gz
+
+ # Do not build with DOS support
+ sed -i -e 's|^all:.*$|all: lilo|' ${S}/Makefile
+ sed -i -e 's|DOS_DIR=/dosC/boot||' ${S}/Makefile
+
+ if use devmap; then
+ # devmapper-patch (boot on evms/lvm2)
+ cd ${S}; epatch ${FILESDIR}/${P}-devmapper_gentoo.patch
+ fi
+
+ cd ${S}
+
+ # Fix creating install dirs, bug #39405
+ epatch ${FILESDIR}/${P}-create-install-dirs.patch
+ # Correctly document commandline options -v and -V, bug #43554
+ epatch ${FILESDIR}/${P}-correct-usage-info.patch
+ # Install manpages to correct location, do not rely on incorrect manpath output, bug #117135
+ epatch ${FILESDIR}/${P}-manpath.patch
+
+ # this patch is needed when booting PXE and the device you're using
+ # emulates vga console via serial console.
+ # IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
+ use pxeserial && epatch ${FILESDIR}/${P}-novga.patch
+
+ unpack ${DOLILO_TAR}
+}
+
+src_compile() {
+ # hardened automatic PIC plus PIE building should be suppressed
+ # because of assembler instructions that cannot be compiled PIC
+ HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"
+
+ # we explicitly prevent the custom CFLAGS for stability reasons
+ if use static; then
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo.static || die
+ mv lilo.static lilo || die
+ else
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo || die
+ fi
+}
+
+src_install() {
+ keepdir /boot
+ make ROOT=${D} install || die
+
+ if use !minimal; then
+ into /
+ dosbin ${S}/dolilo/dolilo
+
+ into /usr
+ dosbin keytab-lilo.pl
+
+ insinto /etc
+ newins ${FILESDIR}/lilo.conf lilo.conf.example
+
+ insinto /etc/conf.d
+ newins ${S}/dolilo/dolilo.conf.d dolilo.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT README*
+ docinto samples ; dodoc sample/*
+ fi
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(mount | grep -v "tmpfs" | grep -v "rootfs" | grep "on / " | cut -f1 -d " ")"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(sed -n "s:^boot[ ]*=[ ]*\(.*\)[ ]*:\1:p" /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ then
+ [ -f "${ROOT}/boot/boot-menu.b" ] && \
+ ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ fi
+
+ if [ "${ROOT}" = "/" ] && use !minimal;
+ then
+ if lilocheck
+ then
+ einfo "Running DOLILO to complete the install ..."
+ # do not redirect to /dev/null because it may display some input
+ # prompt
+ /sbin/dolilo
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/dolilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ ebeep 5
+ epause 5
+ fi
+ fi
+ echo
+ fi
+ if use !minimal; then
+ echo
+ einfo "Issue 'dolilo' instead of 'lilo' to have a friendly wrapper that"
+ einfo "handles mounting and unmounting /boot for you. It can do more then"
+ einfo "that when asked, edit /etc/conf.d/dolilo to harness it's full potential."
+ ebeep 5
+ epause 3
+ echo
+ fi
+}