summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-18 03:15:47 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-18 03:15:47 +0000
commit31f9cc6273b7e9f451fff3a0d7c2faf5b64fd6b5 (patch)
tree58c61d40de5236e462189657766625c85391330b /sys-boot
parentversion bump (diff)
downloadgentoo-2-31f9cc6273b7e9f451fff3a0d7c2faf5b64fd6b5.tar.gz
gentoo-2-31f9cc6273b7e9f451fff3a0d7c2faf5b64fd6b5.tar.bz2
gentoo-2-31f9cc6273b7e9f451fff3a0d7c2faf5b64fd6b5.zip
document the patch, not ebuild
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/files/syslinux-3.70-nopie.patch10
-rw-r--r--sys-boot/syslinux/syslinux-3.70.ebuild5
2 files changed, 8 insertions, 7 deletions
diff --git a/sys-boot/syslinux/files/syslinux-3.70-nopie.patch b/sys-boot/syslinux/files/syslinux-3.70-nopie.patch
index 5d0ccaa71715..4e9c264574c4 100644
--- a/sys-boot/syslinux/files/syslinux-3.70-nopie.patch
+++ b/sys-boot/syslinux/files/syslinux-3.70-nopie.patch
@@ -1,5 +1,7 @@
---- com32/libutil/Makefile.orig 2008-01-02 14:33:58 +0000
-+++ com32/libutil/Makefile 2008-01-02 14:35:38 +0000
+add no PIE flags if the toolchain supports it
+
+--- com32/libutil/Makefile
++++ com32/libutil/Makefile
@@ -34,7 +34,8 @@
gcc_ok = $(shell tmpf=$(TMPFILE); if gcc $(1) -c -x c /dev/null -o $$tmpf 2>/dev/null; \
then echo $(1); else echo $(2); fi; rm -f $$tmpf)
@@ -10,8 +12,8 @@
CC = gcc
LD = ld -m elf_i386
---- com32/modules/Makefile.orig 2008-01-02 14:42:12 +0000
-+++ com32/modules/Makefile 2008-01-02 14:42:50 +0000
+--- com32/modules/Makefile
++++ com32/modules/Makefile
@@ -19,7 +19,8 @@
gcc_ok = $(shell tmpf=$(TMPFILE); if gcc $(1) -c -x c /dev/null -o $$tmpf 2>/dev/null; \
then echo $(1); else echo $(2); fi; rm -f $$tmpf)
diff --git a/sys-boot/syslinux/syslinux-3.70.ebuild b/sys-boot/syslinux/syslinux-3.70.ebuild
index 2d9f9886f276..83f049e115c6 100644
--- a/sys-boot/syslinux/syslinux-3.70.ebuild
+++ b/sys-boot/syslinux/syslinux-3.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.70.ebuild,v 1.1 2008/07/21 23:21:18 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.70.ebuild,v 1.2 2008/08/18 03:15:46 vapier Exp $
inherit eutils
@@ -26,8 +26,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- # Actually compile on uclibc hardened
- epatch "${FILESDIR}/${P}-nopie.patch"
+ epatch "${FILESDIR}"/${P}-nopie.patch
# Don't prestrip, makes portage angry
epatch "${FILESDIR}/${P}-nostrip.patch"
rm -f gethostip #137081