summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdgar Hucek <gimli@gentoo.org>2005-09-15 21:13:07 +0000
committerEdgar Hucek <gimli@gentoo.org>2005-09-15 21:13:07 +0000
commit48354ede2224f64d25b223f43da66793e27fc1b7 (patch)
treefe7844a220c64e2e113f37e4932f971c49105289 /sys-boot
parentMark 1.0.4 stable on alpha (diff)
downloadgentoo-2-48354ede2224f64d25b223f43da66793e27fc1b7.tar.gz
gentoo-2-48354ede2224f64d25b223f43da66793e27fc1b7.tar.bz2
gentoo-2-48354ede2224f64d25b223f43da66793e27fc1b7.zip
Fix gcc 3.4 compile bug
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/cromwell/ChangeLog9
-rw-r--r--sys-boot/cromwell/Manifest4
-rw-r--r--sys-boot/cromwell/cromwell-2.40-r1.ebuild (renamed from sys-boot/cromwell/cromwell-2.31.ebuild)14
-rw-r--r--sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch82
-rw-r--r--sys-boot/cromwell/files/digest-cromwell-2.311
-rw-r--r--sys-boot/cromwell/files/digest-cromwell-2.40-r11
6 files changed, 104 insertions, 7 deletions
diff --git a/sys-boot/cromwell/ChangeLog b/sys-boot/cromwell/ChangeLog
index d5be401f2a3b..abc789d36d94 100644
--- a/sys-boot/cromwell/ChangeLog
+++ b/sys-boot/cromwell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/cromwell
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/cromwell/ChangeLog,v 1.4 2005/08/10 20:39:31 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/cromwell/ChangeLog,v 1.5 2005/09/15 21:13:07 gimli Exp $
+
+*cromwell-2.40-r1 (15 Sep 2005)
+
+ 15 Sep 2005; <gimli@gentoo.org> +files/cromwell-2.40-gcc-3.4.patch,
+ -cromwell-2.31.ebuild, +cromwell-2.40-r1.ebuild:
+ Remove old version.
+ Fix gcc 3.4 compile.
*cromwell-2.40 (10 Aug 2005)
diff --git a/sys-boot/cromwell/Manifest b/sys-boot/cromwell/Manifest
index a376ce30881e..c4bc48ff23bb 100644
--- a/sys-boot/cromwell/Manifest
+++ b/sys-boot/cromwell/Manifest
@@ -1,6 +1,8 @@
MD5 e8edeb1e48878ca9b774a08c651f577f ChangeLog 796
-MD5 1132a3b844170de154e81605672cec5e cromwell-2.31.ebuild 647
MD5 c7b3f94359f9a343a1d9d944dad5c090 cromwell-2.40.ebuild 653
MD5 6fa4899ddcfd1045cf3db88eeda6ceaa metadata.xml 305
+MD5 407e17e2e81262b6c81a4e4cbd91db9b cromwell-2.40-r1.ebuild 643
MD5 5fe7d58e888250525bac16c838cb2cb1 files/digest-cromwell-2.31 67
MD5 115f47bffab07dc390eebe15170d597c files/digest-cromwell-2.40 66
+MD5 e798da345e6655880e9d66c7aeb5e7e9 files/cromwell-2.40-gcc-3.4.patch 2906
+MD5 115f47bffab07dc390eebe15170d597c files/digest-cromwell-2.40-r1 66
diff --git a/sys-boot/cromwell/cromwell-2.31.ebuild b/sys-boot/cromwell/cromwell-2.40-r1.ebuild
index 41ef172cc0c5..06a4f31ac70b 100644
--- a/sys-boot/cromwell/cromwell-2.31.ebuild
+++ b/sys-boot/cromwell/cromwell-2.40-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/cromwell/cromwell-2.31.ebuild,v 1.3 2005/04/28 18:48:46 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/cromwell/cromwell-2.40-r1.ebuild,v 1.1 2005/09/15 21:13:07 gimli Exp $
-inherit mount-boot
+inherit eutils mount-boot
IUSE=""
DESCRIPTION="Xbox boot loader"
@@ -12,9 +12,15 @@ RESTRICT="${RESTRICT} nostrip"
DEPEND=""
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="-* x86"
+KEYWORDS="-* ~x86"
PROVIDE="virtual/bootloader"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}; epatch ${FILESDIR}/${P}-gcc-3.4.patch
+}
+
src_compile() {
emake -j1 || die
}
@@ -22,5 +28,5 @@ src_compile() {
src_install () {
dodir /boot/${PN}
insinto /boot/${PN}
- doins ${S}/image/image.bin ${S}/image/image_1024.bin ${S}/xbe/default.xbe || die
+ doins ${S}/image/cromwell.bin ${S}/image/cromwell_1024.bin ${S}/xbe/xromwell.xbe || die
}
diff --git a/sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch b/sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch
new file mode 100644
index 000000000000..7c2eca631a86
--- /dev/null
+++ b/sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch
@@ -0,0 +1,82 @@
+diff -uNr cromwell-2.40/Makefile cromwell-2.40.patched/Makefile
+--- cromwell-2.40/Makefile 2004-12-02 21:09:50.000000000 +0000
++++ cromwell-2.40.patched/Makefile 2005-09-15 22:51:04.000000000 +0000
+@@ -10,7 +10,7 @@
+ -I$(TOPDIR)/startuploader -I$(TOPDIR)/drivers/cpu \
+ -I$(TOPDIR)/lib/jpeg/
+
+-CFLAGS = -O2 -mcpu=pentium -Werror $(INCLUDE) -Wstrict-prototypes -fomit-frame-pointer -pipe
++CFLAGS = -O2 -mcpu=pentium -Werror $(INCLUDE) -Wstrict-prototypes -fomit-frame-pointer -pipe
+
+ # add the option for gcc 3.3 only
+ ifeq ($(GCC_3.3), 1)
+diff -uNr cromwell-2.40/boot_rom/bootrom.ld cromwell-2.40.patched/boot_rom/bootrom.ld
+--- cromwell-2.40/boot_rom/bootrom.ld 2003-09-08 11:04:06.000000000 +0000
++++ cromwell-2.40.patched/boot_rom/bootrom.ld 2005-09-15 22:54:24.000000000 +0000
+@@ -45,6 +45,7 @@
+ .rodata ( RAM_CODE + SIZEOF(.text) + SIZEOF(.data) ) : AT ( SIZEOF(.low_rom) + SIZEOF(.text) + SIZEOF(.data)) {
+ *(.rodata);
+ *(.rodata.str1.1);
++ *(.rodata.str1.4);
+ *(.rodata.str1.32);
+ *(.rodata.cst4);
+ *(.rodata.cst8);
+diff -uNr cromwell-2.40/fs/grub/fsys_reiserfs.c cromwell-2.40.patched/fs/grub/fsys_reiserfs.c
+--- cromwell-2.40/fs/grub/fsys_reiserfs.c 2004-06-06 14:50:43.000000000 +0000
++++ cromwell-2.40.patched/fs/grub/fsys_reiserfs.c 2005-09-15 22:53:35.000000000 +0000
+@@ -367,7 +367,7 @@
+
+
+ static __inline__ unsigned long
+-log2 (unsigned long word)
++reiser_log2 (unsigned long word)
+ {
+ __asm__ ("bsfl %1,%0"
+ : "=r" (word)
+@@ -609,7 +609,7 @@
+
+ INFO->version = super.s_version;
+ INFO->blocksize = super.s_blocksize;
+- INFO->fullblocksize_shift = log2 (super.s_blocksize);
++ INFO->fullblocksize_shift = reiser_log2 (super.s_blocksize);
+ INFO->blocksize_shift = INFO->fullblocksize_shift - SECTOR_BITS;
+ INFO->cached_slots =
+ (FSYSREISER_CACHE_SIZE >> INFO->fullblocksize_shift) - 1;
+diff -uNr cromwell-2.40/lib/gzip/misc.c cromwell-2.40.patched/lib/gzip/misc.c
+--- cromwell-2.40/lib/gzip/misc.c 2004-06-06 14:27:26.000000000 +0000
++++ cromwell-2.40.patched/lib/gzip/misc.c 2005-09-15 22:52:55.000000000 +0000
+@@ -29,8 +29,6 @@
+ *
+ * Incomprehensible are the ways of bootloaders.
+ */
+-static void* memset(void *, int, size_t);
+-static void* memcpy(void *, __const void *, size_t);
+ #define memzero(s, n) memset ((s), 0, (n))
+
+ typedef unsigned char uch;
+@@ -138,25 +136,6 @@
+ free_mem_ptr = (long) *ptr;
+ }
+
+-static void* memset(void* s, int c, size_t n)
+-{
+- int i;
+- char *ss = (char*)s;
+-
+- for (i=0;i<n;i++) ss[i] = c;
+- return s;
+-}
+-
+-static void* memcpy(void* __dest, __const void* __src,
+- size_t __n)
+-{
+- int i;
+- char *d = (char *)__dest, *s = (char *)__src;
+-
+- for (i=0;i<__n;i++) d[i] = s[i];
+- return __dest;
+-}
+-
+ /* ===========================================================================
+ * Fill the input buffer. This is called only when the buffer is empty
+ * and at least one byte is really needed.
diff --git a/sys-boot/cromwell/files/digest-cromwell-2.31 b/sys-boot/cromwell/files/digest-cromwell-2.31
deleted file mode 100644
index e42a9bc76e10..000000000000
--- a/sys-boot/cromwell/files/digest-cromwell-2.31
+++ /dev/null
@@ -1 +0,0 @@
-MD5 04e3b9fd38fe6f831cab5b01ddc3a039 cromwell-2.31.tar.bz2 2866836
diff --git a/sys-boot/cromwell/files/digest-cromwell-2.40-r1 b/sys-boot/cromwell/files/digest-cromwell-2.40-r1
new file mode 100644
index 000000000000..d7e7427b39b7
--- /dev/null
+++ b/sys-boot/cromwell/files/digest-cromwell-2.40-r1
@@ -0,0 +1 @@
+MD5 a6c9789cfa07f52de826c12681bbd595 cromwell-2.40.tar.bz2 943015