summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-03 15:11:57 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-03 15:11:57 +0000
commit72ff611735b9efa5f4109e4ff778d329d155f3e9 (patch)
treeeaf3b67b78e8393eec7b4b8facae02723909437d /sys-boot
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-72ff611735b9efa5f4109e4ff778d329d155f3e9.tar.gz
gentoo-2-72ff611735b9efa5f4109e4ff778d329d155f3e9.tar.bz2
gentoo-2-72ff611735b9efa5f4109e4ff778d329d155f3e9.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-466.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 07d2bcb4c7e6..7ba068eb2733 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.40 2010/06/02 20:18:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.41 2010/06/03 15:11:57 jer Exp $
+
+*unetbootin-466 (03 Jun 2010)
+
+ 03 Jun 2010; Jeroen Roovers <jer@gentoo.org> +unetbootin-466.ebuild:
+ Version bump.
*unetbootin-456 (02 Jun 2010)
diff --git a/sys-boot/unetbootin/unetbootin-466.ebuild b/sys-boot/unetbootin/unetbootin-466.ebuild
new file mode 100644
index 000000000000..fd918404c447
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-466.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-466.ebuild,v 1.1 2010/06/03 15:11:57 jer Exp $
+
+inherit qt4
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_compile() {
+ lupdate unetbootin.pro || die "lupdate failed"
+ lrelease unetbootin.pro || die "lrelease failed"
+ eqmake4 unetbootin.pro || die "eqmake4 failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin unetbootin || die "dobin failed"
+ insinto /usr/share/applications
+ doins unetbootin.desktop || die "doins failed"
+}