summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2006-06-19 20:43:38 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2006-06-19 20:43:38 +0000
commitc71a23f8c9f65e384c1ff04979728d654ae3f95b (patch)
treea1f0beed3927ed730c5921a75682b8e4c32cfebf /sys-boot
parentStable on x86, bug #134960. (diff)
downloadgentoo-2-c71a23f8c9f65e384c1ff04979728d654ae3f95b.tar.gz
gentoo-2-c71a23f8c9f65e384c1ff04979728d654ae3f95b.tar.bz2
gentoo-2-c71a23f8c9f65e384c1ff04979728d654ae3f95b.zip
Revbump with the iso patch, hopefully fixes CD issues
(Portage version: 2.1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/silo/ChangeLog8
-rw-r--r--sys-boot/silo/files/digest-silo-1.4.12-r13
-rw-r--r--sys-boot/silo/files/silo-1.4.12-iso.patch35
-rw-r--r--sys-boot/silo/silo-1.4.12-r1.ebuild56
4 files changed, 101 insertions, 1 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 681d6d33147a..3f253e737560 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/silo
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.29 2006/06/16 20:32:54 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.30 2006/06/19 20:43:38 gustavoz Exp $
+
+*silo-1.4.12-r1 (19 Jun 2006)
+
+ 19 Jun 2006; Gustavo Zacarias <gustavoz@gentoo.org>
+ +files/silo-1.4.12-iso.patch, +silo-1.4.12-r1.ebuild:
+ Revbump with the iso patch, hopefully fixes CD issues
*silo-1.4.12 (16 Jun 2006)
diff --git a/sys-boot/silo/files/digest-silo-1.4.12-r1 b/sys-boot/silo/files/digest-silo-1.4.12-r1
new file mode 100644
index 000000000000..8204879f40ac
--- /dev/null
+++ b/sys-boot/silo/files/digest-silo-1.4.12-r1
@@ -0,0 +1,3 @@
+MD5 15e77558c57cae19a790fc100783d8f3 silo-1.4.12.tar.gz 168839
+RMD160 68ec1291630c7d1e58f6d52f31529c226fa982b0 silo-1.4.12.tar.gz 168839
+SHA256 232d23a18236a71bff3c9fe0d081a7bbb5913056a4637496782401b0ed5bdf60 silo-1.4.12.tar.gz 168839
diff --git a/sys-boot/silo/files/silo-1.4.12-iso.patch b/sys-boot/silo/files/silo-1.4.12-iso.patch
new file mode 100644
index 000000000000..3dc8d7b86f65
--- /dev/null
+++ b/sys-boot/silo/files/silo-1.4.12-iso.patch
@@ -0,0 +1,35 @@
+--- first-isofs/isofs.c.~1~ 2006-06-18 19:05:53.000000000 -0700
++++ first-isofs/isofs.c 2006-06-18 19:06:08.000000000 -0700
+@@ -101,6 +101,23 @@
+ return 0;
+ }
+
++static void cd_fini(void)
++{
++ switch (prom_vers) {
++ case PROM_V0:
++ romvec->pv_v0devops.v0_devclose(fd);
++ break;
++
++ case PROM_V2:
++ case PROM_V3:
++ romvec->pv_v2devops.v2_dev_close(fd);
++ break;
++
++ case PROM_P1275:
++ p1275_cmd("close", 1, fd);
++ break;
++ };
++}
+
+ static int cd_read_block(unsigned long long offset, int size, void *data)
+ {
+@@ -445,6 +462,8 @@
+ sinfo->conf_part = 1;
+ strcpy(sinfo->conf_file, silo_conf);
+
++ cd_fini();
++
+ prom_putchar(sinfo->id);
+
+ return dest;
diff --git a/sys-boot/silo/silo-1.4.12-r1.ebuild b/sys-boot/silo/silo-1.4.12-r1.ebuild
new file mode 100644
index 000000000000..22f13ddedd17
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.12-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.12-r1.ebuild,v 1.1 2006/06/19 20:43:38 gustavoz Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/silo-1.4.x-noglibc_time.patch
+ epatch ${FILESDIR}/silo-1.4.12-iso.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}