summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-01-11 16:01:08 +0000
committerJeroen Roovers <jer@gentoo.org>2009-01-11 16:01:08 +0000
commitcc4a92d58cec4cba131083853ad550242492635f (patch)
tree6bd808ca7ca8dda2737d93467042fc9071fd76cd /sys-boot
parentx86 stable, bug #253663 (diff)
downloadgentoo-2-cc4a92d58cec4cba131083853ad550242492635f.tar.gz
gentoo-2-cc4a92d58cec4cba131083853ad550242492635f.tar.bz2
gentoo-2-cc4a92d58cec4cba131083853ad550242492635f.zip
Marked ~amd64 thanks to Markos Chandras and Xavier Neys (bug #254316). Apply syslinux patch thanks to Xavier Neys (bug #254419).
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog10
-rw-r--r--sys-boot/unetbootin/files/unetbootin-304-syslinux-gentoo.patch17
-rw-r--r--sys-boot/unetbootin/unetbootin-304-r1.ebuild (renamed from sys-boot/unetbootin/unetbootin-304.ebuild)11
3 files changed, 35 insertions, 3 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 5078d398ea92..6aae7ad04a9a 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.1 2009/01/08 18:12:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.2 2009/01/11 16:01:08 jer Exp $
+
+*unetbootin-304-r1 (11 Jan 2009)
+
+ 11 Jan 2009; Jeroen Roovers <jer@gentoo.org>
+ +files/unetbootin-304-syslinux-gentoo.patch, -unetbootin-304.ebuild,
+ +unetbootin-304-r1.ebuild:
+ Marked ~amd64 thanks to Markos Chandras and Xavier Neys (bug #254316).
+ Apply syslinux patch thanks to Xavier Neys (bug #254419).
*unetbootin-304 (08 Jan 2009)
diff --git a/sys-boot/unetbootin/files/unetbootin-304-syslinux-gentoo.patch b/sys-boot/unetbootin/files/unetbootin-304-syslinux-gentoo.patch
new file mode 100644
index 000000000000..ce9425668566
--- /dev/null
+++ b/sys-boot/unetbootin/files/unetbootin-304-syslinux-gentoo.patch
@@ -0,0 +1,17 @@
+--- unetbootin.cpp.orig 2009-01-10 14:30:50.000000000 +0100
++++ unetbootin.cpp 2009-01-10 14:39:43.000000000 +0100
+@@ -2219,11 +2219,11 @@
+ QFile srcF(QString(":/%1").arg(srcfName));
+ #ifdef NOSTATIC
+ if (srcfName == "memdisk")
+- srcF.setFileName("/usr/lib/syslinux/memdisk");
++ srcF.setFileName(QFile::exists("/usr/share/syslinux/memdisk") ? "/usr/share/syslinux/memdisk" : "/usr/lib/syslinux/memdisk");
+ else if (srcfName == "vesamenu.c32")
+- srcF.setFileName("/usr/lib/syslinux/vesamenu.c32");
++ srcF.setFileName(QFile::exists("/usr/share/syslinux/vesamenu.c32") ? "/usr/share/syslinux/vesamenu.c32" : "/usr/lib/syslinux/vesamenu.c32");
+ else if (srcfName == "mbr.bin")
+- srcF.setFileName("/usr/lib/syslinux/mbr.bin");
++ srcF.setFileName(QFile::exists("/usr/share/syslinux/mbr.bin") ? "/usr/share/syslinux/mbr.bin" : "/usr/lib/syslinux/mbr.bin");
+ else if (srcfName == "ubnsylnx")
+ srcF.setFileName("/usr/bin/syslinux");
+ // else
diff --git a/sys-boot/unetbootin/unetbootin-304.ebuild b/sys-boot/unetbootin/unetbootin-304-r1.ebuild
index df0f2e1f0b0d..1728f9ef0b34 100644
--- a/sys-boot/unetbootin/unetbootin-304.ebuild
+++ b/sys-boot/unetbootin/unetbootin-304-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-304.ebuild,v 1.1 2009/01/08 18:12:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-304-r1.ebuild,v 1.1 2009/01/11 16:01:08 jer Exp $
+
+inherit eutils
DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
distributions."
@@ -9,7 +11,7 @@ SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
S="${WORKDIR}"
@@ -20,6 +22,11 @@ RDEPEND="${DEPEND}
sys-boot/syslinux
app-arch/p7zip"
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-syslinux-gentoo.patch
+}
+
src_compile() {
./INSTALL || die "compile failed!"
}