summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-07-13 18:05:19 +0000
committerMike Gilbert <floppym@gentoo.org>2012-07-13 18:05:19 +0000
commite4ae72eab75690cf1451d2380338274d743149d0 (patch)
tree7ddf49f2eb64ee47191d4693daddae74451d6acc /sys-boot
parentUpdate DISTUTILS_GLOBAL_OPTIONS to match EAPI 4 logic in distutils.eclass as ... (diff)
downloadgentoo-2-e4ae72eab75690cf1451d2380338274d743149d0.tar.gz
gentoo-2-e4ae72eab75690cf1451d2380338274d743149d0.tar.bz2
gentoo-2-e4ae72eab75690cf1451d2380338274d743149d0.zip
Add mulitprocessing.eclass magic to src_configure.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-2.00.ebuild8
-rw-r--r--sys-boot/grub/grub-9999.ebuild8
3 files changed, 15 insertions, 7 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 648bb8862311..3fce2341c746 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.227 2012/07/07 22:55:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.228 2012/07/13 18:05:19 floppym Exp $
+
+ 13 Jul 2012; Mike Gilbert <floppym@gentoo.org> grub-2.00.ebuild,
+ grub-9999.ebuild:
+ Add mulitprocessing.eclass magic to src_configure.
07 Jul 2012; Mike Gilbert <floppym@gentoo.org>
+files/grub-2.00-parallel-make.patch, -files/grub-2.00-manpage-race.patch,
diff --git a/sys-boot/grub/grub-2.00.ebuild b/sys-boot/grub/grub-2.00.ebuild
index 4be1e7ce7305..9f571cbda9b6 100644
--- a/sys-boot/grub/grub-2.00.ebuild
+++ b/sys-boot/grub/grub-2.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.12 2012/07/07 22:55:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.13 2012/07/13 18:05:19 floppym Exp $
EAPI=4
@@ -22,7 +22,7 @@ else
DO_AUTORECONF="true"
fi
-inherit eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
+inherit eutils flag-o-matic multiprocessing pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
unset LIVE_ECLASS
DESCRIPTION="GNU GRUB boot loader"
@@ -253,9 +253,11 @@ src_configure() {
# Sandbox bug 404013.
use libzfs && addpredict /etc/dfs:/dev/zfs
+ multijob_init
for i in ${GRUB_ENABLED_PLATFORMS}; do
- grub_run_phase ${FUNCNAME} ${i}
+ multijob_child_init grub_run_phase ${FUNCNAME} ${i}
done
+ multijob_finish || die
}
src_compile() {
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 443d64245e06..23f254c85347 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.77 2012/07/07 22:55:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.78 2012/07/13 18:05:19 floppym Exp $
EAPI=4
@@ -22,7 +22,7 @@ else
DO_AUTORECONF="true"
fi
-inherit eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
+inherit eutils flag-o-matic multiprocessing pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
unset LIVE_ECLASS
DESCRIPTION="GNU GRUB boot loader"
@@ -253,9 +253,11 @@ src_configure() {
# Sandbox bug 404013.
use libzfs && addpredict /etc/dfs:/dev/zfs
+ multijob_init
for i in ${GRUB_ENABLED_PLATFORMS}; do
- grub_run_phase ${FUNCNAME} ${i}
+ multijob_child_init grub_run_phase ${FUNCNAME} ${i}
done
+ multijob_finish || die
}
src_compile() {