summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-03-06 21:25:32 +0000
committerJonathan Callen <abcd@gentoo.org>2010-03-06 21:25:32 +0000
commitf13be535a450cc3c607897e4f087c4ea1f5241cf (patch)
treed9c2684089af80f9db7873b742ed35ef17a0508c /sys-boot
parentx86 stable wrt bug #304775 (diff)
downloadgentoo-2-f13be535a450cc3c607897e4f087c4ea1f5241cf.tar.gz
gentoo-2-f13be535a450cc3c607897e4f087c4ea1f5241cf.tar.bz2
gentoo-2-f13be535a450cc3c607897e4f087c4ea1f5241cf.zip
Version bump; update metadata.xml
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/os-prober/ChangeLog10
-rw-r--r--sys-boot/os-prober/metadata.xml9
-rw-r--r--sys-boot/os-prober/os-prober-1.36.ebuild72
3 files changed, 85 insertions, 6 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index 996a55ecfe3e..136152686a97 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/os-prober
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.2 2009/12/15 21:37:03 abcd Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.3 2010/03/06 21:25:32 abcd Exp $
+
+*os-prober-1.36 (06 Mar 2010)
+
+ 06 Mar 2010; Jonathan Callen <abcd@gentoo.org> +os-prober-1.36.ebuild,
+ metadata.xml:
+ Version bump; update metadata.xml
15 Dec 2009; Jonathan Callen <abcd@gentoo.org> os-prober-1.35.ebuild:
Add elog about NTFS to postinst
diff --git a/sys-boot/os-prober/metadata.xml b/sys-boot/os-prober/metadata.xml
index 5f841955c0b5..78a58c38e14c 100644
--- a/sys-boot/os-prober/metadata.xml
+++ b/sys-boot/os-prober/metadata.xml
@@ -3,11 +3,12 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>abcd@gentoo.org</email>
- <name>Jonathan Callen</name>
+ <email>wizzleby@gmail.com</email>
+ <name>Locke Shinseiko</name>
</maintainer>
<maintainer>
- <email>wizzleby@gmail.com</email>
- <name>Wizzleby</name>
+ <email>abcd@gentoo.org</email>
+ <name>Jonathan Callen</name>
+ <description>Proxy maintainer (CC bugs)</description>
</maintainer>
</pkgmetadata>
diff --git a/sys-boot/os-prober/os-prober-1.36.ebuild b/sys-boot/os-prober/os-prober-1.36.ebuild
new file mode 100644
index 000000000000..4a353a0a7fc2
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.36.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.36.ebuild,v 1.1 2010/03/06 21:25:32 abcd Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s:/lib/udev:/$(get_libdir)/udev:g" common.sh || die "sed failed on common.sh"
+ find "${S}" -type f -exec sed -i -e "s:/usr/lib/:/usr/libexec/:g" {} + || die "failed on find and sed lib->libexec"
+ sed -i -e "s:/lib/ld\*\.so\*:/lib*/ld*.so*:g" os-probes/mounted/common/90linux-distro || die "sed failed on 90linux-distro"
+
+ # Just use the default rules provided by GNU Make
+ rm Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake newns || die "emake failed"
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober || die "dobin failed"
+
+ exeinto /usr/libexec/os-prober
+ doexe newns || die "doexe newns failed"
+
+ insinto /usr/share/os-prober
+ doins common.sh || die "doins common.sh failed"
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/libexec/$dir
+ doexe $dir/common/* || die "doexe failed in $dir/common"
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/* || die "doexe failed in $dir/$debarch"
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/libexec/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx || die "doexe failed on 20macosx"
+ fi
+
+ dodoc README TODO debian/changelog || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}