summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 09:58:00 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 09:58:00 +0000
commit5d08a8650f0f0fc5056c74103ae903705daae850 (patch)
tree39899d987bca81afef4b8d3dd6190bc407a2bbd7 /sys-cluster/mpich2
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-5d08a8650f0f0fc5056c74103ae903705daae850.tar.gz
gentoo-2-5d08a8650f0f0fc5056c74103ae903705daae850.tar.bz2
gentoo-2-5d08a8650f0f0fc5056c74103ae903705daae850.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/mpich2')
-rw-r--r--sys-cluster/mpich2/ChangeLog6
-rw-r--r--sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild7
-rw-r--r--sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild5
3 files changed, 12 insertions, 6 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index cd6a1b8d150d..e1714c472220 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.71 2011/06/12 22:37:21 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.72 2011/06/21 09:57:59 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> mpich2-1.2.1_p1-r1.ebuild,
+ mpich2-1.4_rc2-r1.ebuild:
+ Added fortran-2.eclass support
*mpich2-1.4_rc2-r1 (12 Jun 2011)
diff --git a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
index 14508be1bc45..cf568d0f7724 100644
--- a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.11 2010/12/19 19:12:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.12 2011/06/21 09:57:59 jlec Exp $
EAPI=2
PYTHON_DEPEND="2"
-inherit eutils python toolchain-funcs
+inherit eutils fortran-2 python toolchain-funcs
MY_PV=${PV/_/}
DESCRIPTION="MPICH2 - A portable MPI implementation"
@@ -32,6 +32,7 @@ RDEPEND="${COMMON_DEPEND}
S="${WORKDIR}"/${PN}-${MY_PV}
pkg_setup() {
+ fortran-2_pkg_setup
python_set_active_version 2
python_pkg_setup
diff --git a/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild b/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
index 19aea7b5260e..f16ed31a5994 100644
--- a/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild,v 1.2 2011/06/13 15:01:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild,v 1.3 2011/06/21 09:58:00 jlec Exp $
EAPI=2
-inherit eutils toolchain-funcs autotools
+inherit eutils fortran-2 toolchain-funcs autotools
MY_PV=${PV/_/}
DESCRIPTION="MPICH2 - A portable MPI implementation"
@@ -31,6 +31,7 @@ RDEPEND="${COMMON_DEPEND}
S="${WORKDIR}"/${PN}-${MY_PV}
pkg_setup() {
+ fortran-2_pkg_setup
if use mpi-threads && ! use threads; then
ewarn "mpi-threads requires threads, assuming that's what you want"
fi