summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-05 19:22:12 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-05 19:22:12 +0000
commit0e02d789be6718e2af699e66790cff004c582192 (patch)
tree04cc0141c76d51ed88943ed1103b6536fe23e0b5 /sys-cluster
parentremove ptex dep as it is going away (diff)
downloadgentoo-2-0e02d789be6718e2af699e66790cff004c582192.tar.gz
gentoo-2-0e02d789be6718e2af699e66790cff004c582192.tar.bz2
gentoo-2-0e02d789be6718e2af699e66790cff004c582192.zip
[sys-cluster/ceph] Version bump
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ChangeLog7
-rw-r--r--sys-cluster/ceph/ceph-0.36.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 95d4f6fb431d..3604516a842b 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.12 2011/08/31 17:29:31 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.13 2011/10/05 19:22:12 alexxy Exp $
+
+*ceph-0.36 (05 Oct 2011)
+
+ 05 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +ceph-0.36.ebuild:
+ Version bump
*ceph-0.34 (31 Aug 2011)
diff --git a/sys-cluster/ceph/ceph-0.36.ebuild b/sys-cluster/ceph/ceph-0.36.ebuild
new file mode 100644
index 000000000000..7bbc1fb0d292
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.36.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.36.ebuild,v 1.1 2011/10/05 19:22:12 alexxy Exp $
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.newdream.net/"
+SRC_URI="http://ceph.newdream.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fuse gtk libatomic radosgw static-libs"
+
+CDEPEND="
+ dev-libs/boost
+ dev-libs/libedit
+ dev-libs/crypto++
+ sys-apps/keyutils
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ )
+ "
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
+ -i src/logrotate.conf || die
+ sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
+ # disable testsnaps
+ sed -e '/testsnaps/d' -i src/Makefile.am || die
+ epatch "${FILESDIR}/${PN}-0.26-autotools.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --without-tcmalloc \
+ --docdir=/usr/share/doc/${PF} \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -type f -name "*.la" -exec rm -f {} \;
+
+ rmdir "${D}/usr/sbin"
+
+ exeinto /usr/$(get_libdir)/ceph || die
+ newexe src/init-ceph ceph_init.sh || die
+
+ insinto /etc/logrotate.d/ || die
+ newins src/logrotate.conf ${PN} || die
+
+ chmod 644 "${D}"/usr/share/doc/${PF}/sample.* || die
+
+ keepdir /var/lib/${PN} || die
+ keepdir /var/lib/${PN}/tmp || die
+ keepdir /var/log/${PN}/stat || die
+ keepdir /var/run/${PN} || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die
+}