summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-10-11 23:11:57 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-10-11 23:11:57 +0000
commit264b69cc7e85758fdebeed84bac1a1bdb472e3b2 (patch)
treecd5e26f51db1052683b63cecd044bd62e75cdc1f /sys-cluster
parentbup (diff)
downloadgentoo-2-264b69cc7e85758fdebeed84bac1a1bdb472e3b2.tar.gz
gentoo-2-264b69cc7e85758fdebeed84bac1a1bdb472e3b2.tar.bz2
gentoo-2-264b69cc7e85758fdebeed84bac1a1bdb472e3b2.zip
forgot the linux module checking
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/cinder/ChangeLog6
-rw-r--r--sys-cluster/cinder/cinder-2014.1.3.ebuild11
-rw-r--r--sys-cluster/cinder/cinder-2014.1.9999.ebuild11
3 files changed, 23 insertions, 5 deletions
diff --git a/sys-cluster/cinder/ChangeLog b/sys-cluster/cinder/ChangeLog
index 8416c0ca2343..332e6284ca39 100644
--- a/sys-cluster/cinder/ChangeLog
+++ b/sys-cluster/cinder/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/cinder
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.44 2014/10/11 22:33:53 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.45 2014/10/11 23:11:57 prometheanfire Exp $
+
+ 11 Oct 2014; Matthew Thode <prometheanfire@gentoo.org> cinder-2014.1.3.ebuild,
+ cinder-2014.1.9999.ebuild:
+ forgot the linux module checking
*cinder-2014.1.3 (11 Oct 2014)
diff --git a/sys-cluster/cinder/cinder-2014.1.3.ebuild b/sys-cluster/cinder/cinder-2014.1.3.ebuild
index 27b1b559c2d7..3f2b88a36cd5 100644
--- a/sys-cluster/cinder/cinder-2014.1.3.ebuild
+++ b/sys-cluster/cinder/cinder-2014.1.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2014.1.3.ebuild,v 1.1 2014/10/11 22:33:53 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2014.1.3.ebuild,v 1.2 2014/10/11 23:11:57 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils user
+inherit distutils-r1 eutils linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
HOMEPAGE="https://launchpad.net/cinder"
@@ -96,6 +96,13 @@ RDEPEND=">=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
PATCHES=( )
pkg_setup() {
+ linux-info_pkg_setup
+ CONFIG_CHECK_MODULES="ISCSI_TCP"
+ if linux_config_exists; then
+ for module in ${CONFIG_CHECK_MODULES}; do
+ linux_chkconfig_present ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
+ done
+ fi
enewgroup cinder
enewuser cinder -1 -1 /var/lib/cinder cinder
}
diff --git a/sys-cluster/cinder/cinder-2014.1.9999.ebuild b/sys-cluster/cinder/cinder-2014.1.9999.ebuild
index a3a9046d34ec..ef508df3e107 100644
--- a/sys-cluster/cinder/cinder-2014.1.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2014.1.9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2014.1.9999.ebuild,v 1.6 2014/10/11 22:33:53 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2014.1.9999.ebuild,v 1.7 2014/10/11 23:11:57 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils git-2 user
+inherit distutils-r1 eutils git-2 linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
HOMEPAGE="https://launchpad.net/cinder"
@@ -97,6 +97,13 @@ RDEPEND=">=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
PATCHES=( )
pkg_setup() {
+ linux-info_pkg_setup
+ CONFIG_CHECK_MODULES="ISCSI_TCP"
+ if linux_config_exists; then
+ for module in ${CONFIG_CHECK_MODULES}; do
+ linux_chkconfig_present ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
+ done
+ fi
enewgroup cinder
enewuser cinder -1 -1 /var/lib/cinder cinder
}