summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-05-09 13:27:27 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-05-09 13:27:27 +0000
commit4a5d0909b6641257221942a24c7d75784d05586e (patch)
tree6b6e70667f1c3b26d2a5adcb42c44d14ad662f4e /sys-cluster
parentversion bump to allow to compile against newer ffmpeg (bug 218097) (diff)
downloadgentoo-2-4a5d0909b6641257221942a24c7d75784d05586e.tar.gz
gentoo-2-4a5d0909b6641257221942a24c7d75784d05586e.tar.bz2
gentoo-2-4a5d0909b6641257221942a24c7d75784d05586e.zip
Fixed broken patch (bug #220877).
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog6
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.0.6-fPIC.patch86
2 files changed, 49 insertions, 43 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index a0854bb28ff6..d4facc2c07cd 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.27 2008/03/22 00:56:29 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.28 2008/05/09 13:27:27 markusle Exp $
+
+ 09 May 2008; Markus Dittrich <markusle@gentoo.org>
+ files/mpich2-1.0.6-fPIC.patch:
+ Fixed broken patch (bug #220877).
22 Mar 2008; Steve Arnold <nerdboy@gentoo.org> mpich2-1.0.3.ebuild:
fixed QA issues in oldest versions (mostly string quoting)
diff --git a/sys-cluster/mpich2/files/mpich2-1.0.6-fPIC.patch b/sys-cluster/mpich2/files/mpich2-1.0.6-fPIC.patch
index 33fee9aa49c5..00b6d6a87acd 100644
--- a/sys-cluster/mpich2/files/mpich2-1.0.6-fPIC.patch
+++ b/sys-cluster/mpich2/files/mpich2-1.0.6-fPIC.patch
@@ -1,13 +1,35 @@
---- configure.orig 2007-10-10 20:59:53.000000000 -0700
-+++ configure 2007-10-10 21:04:17.000000000 -0700
-@@ -8783,24 +8783,24 @@
+diff -Naur mpich2-1.0.6p1/confdb/aclocal_shl.m4 mpich2-1.0.6p1.new/confdb/aclocal_shl.m4
+--- mpich2-1.0.6p1/confdb/aclocal_shl.m4 2007-05-16 09:39:01.000000000 -0400
++++ mpich2-1.0.6p1.new/confdb/aclocal_shl.m4 2008-05-09 09:04:35.000000000 -0400
+@@ -89,7 +89,7 @@
+ # For example, include the libname as ${LIBNAME_SHL}
+ #C_LINK_SHL='${CC} -shared -Wl,-h,<finallibname>'
+ # May need -fPIC
+- CC_SHL='${CC} -fpic'
++ CC_SHL='${CC} -fPIC'
+ #C_LINKPATH_SHL="-Wl,-rpath -Wl,"
+ # More recent versions allow multiple args, separated by commas
+ C_LINKPATH_SHL="-Wl,-rpath,"
+@@ -233,7 +233,7 @@
+ gcc)
+ # For example, include the libname as ${LIBNAME_SHL}
+ #C_LINK_SHL='${CC} -shared -Wl,-h,<finallibname>'
+- pac_cc_sharedlibs='gcc -shared -fpic'
++ pac_cc_sharedlibs='gcc -shared -fPIC'
+ pac_clink_sharedlibs='gcc -shared'
+ ;;
+ libtool)
+diff -Naur mpich2-1.0.6p1/configure mpich2-1.0.6p1.new/configure
+--- mpich2-1.0.6p1/configure 2008-05-09 09:08:14.000000000 -0400
++++ mpich2-1.0.6p1.new/configure 2008-05-09 09:06:52.000000000 -0400
+@@ -9061,24 +9061,24 @@
# if the compiler allows it (e.g., building with gcc but
# a different Fortran compiler. Another option is to
# *require* g77.
-- { echo "$as_me:$LINENO: checking whether $F77 allows -shared -fpic" >&5
--echo $ECHO_N "checking whether $F77 allows -shared -fpic... $ECHO_C" >&6; }
-+ { echo "$as_me:$LINENO: checking whether $F77 allows -shared -fPIC" >&5
-+echo $ECHO_N "checking whether $F77 allows -shared -fPIC... $ECHO_C" >&6; }
+- { $as_echo "$as_me:$LINENO: checking whether $F77 allows -shared -fpic" >&5
+-$as_echo_n "checking whether $F77 allows -shared -fpic... " >&6; }
++ { $as_echo "$as_me:$LINENO: checking whether $F77 allows -shared -fPIC" >&5
++$as_echo_n "checking whether $F77 allows -shared -fPIC... " >&6; }
rm -f conftest.f
cat > conftest.f <<EOF
program main
@@ -17,23 +39,23 @@
- FC_SHL="$F77 -shared -fpic"
+ if $F77 -shared -fPIC -o conftest conftest.f >/dev/null 2>&1 ; then
+ FC_SHL="$F77 -shared -fPIC"
- { echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6; }
+ { $as_echo "$as_me:$LINENO: result: yes" >&5
+ $as_echo "yes" >&6; }
else
- { echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6; }
-- { echo "$as_me:$LINENO: checking whether $F77 allows -fpic" >&5
--echo $ECHO_N "checking whether $F77 allows -fpic... $ECHO_C" >&6; }
+ { $as_echo "$as_me:$LINENO: result: no" >&5
+ $as_echo "no" >&6; }
+- { $as_echo "$as_me:$LINENO: checking whether $F77 allows -fpic" >&5
+-$as_echo_n "checking whether $F77 allows -fpic... " >&6; }
- if $F77 -fpic -o conftest conftest.f >/dev/null 2>&1 ; then
- FC_SHL="$F77 -fpic"
-+ { echo "$as_me:$LINENO: checking whether $F77 allows -fPIC" >&5
-+echo $ECHO_N "checking whether $F77 allows -fPIC... $ECHO_C" >&6; }
++ { $as_echo "$as_me:$LINENO: checking whether $F77 allows -fPIC" >&5
++$as_echo_n "checking whether $F77 allows -fPIC... " >&6; }
+ if $F77 -fPIC -o conftest conftest.f >/dev/null 2>&1 ; then
+ FC_SHL="$F77 -fPIC"
- { echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6; }
+ { $as_echo "$as_me:$LINENO: result: yes" >&5
+ $as_echo "yes" >&6; }
else
-@@ -9837,7 +9837,7 @@
+@@ -10118,7 +10118,7 @@
gcc)
if test "$pac_cv_f90_vendor" = gnu -o "$F90" = "g95" ; then
# If we have the GNU Fortran 95 compiler (untested)
@@ -42,7 +64,7 @@
F90_LINKPATH_SHL="-Wl,-rpath -Wl,"
else
case "$pac_cv_f90_vendor" in
-@@ -9848,13 +9848,13 @@
+@@ -10129,13 +10129,13 @@
intel)
# Intel implements the GNU options
@@ -58,7 +80,7 @@
F90_LINKPATH_SHL="-Wl,-rpath -Wl,"
;;
-@@ -10852,7 +10852,7 @@
+@@ -11155,7 +11155,7 @@
;;
gcc)
# Assume that the compiler is g++ if gcc style shared libraries chosen
@@ -67,7 +89,7 @@
CXX_LINKPATH_SHL="-Wl,-rpath -Wl,"
;;
cygwin|cygwin-gcc)
-@@ -12571,7 +12571,7 @@
+@@ -12906,7 +12906,7 @@
# For example, include the libname as ${LIBNAME_SHL}
#C_LINK_SHL='${CC} -shared -Wl,-h,<finallibname>'
# May need -fPIC
@@ -76,27 +98,7 @@
#C_LINKPATH_SHL="-Wl,-rpath -Wl,"
# More recent versions allow multiple args, separated by commas
C_LINKPATH_SHL="-Wl,-rpath,"
-@@ -12839,7 +12839,7 @@
- gcc)
- # For example, include the libname as ${LIBNAME_SHL}
- #C_LINK_SHL='${CC} -shared -Wl,-h,<finallibname>'
-- pac_cc_sharedlibs='gcc -shared -fpic'
-+ pac_cc_sharedlibs='gcc -shared -fPIC'
- pac_clink_sharedlibs='gcc -shared'
- ;;
- libtool)
---- confdb/aclocal_shl.m4.orig 2007-05-16 06:39:01.000000000 -0700
-+++ confdb/aclocal_shl.m4 2007-10-10 21:05:15.000000000 -0700
-@@ -89,7 +89,7 @@
- # For example, include the libname as ${LIBNAME_SHL}
- #C_LINK_SHL='${CC} -shared -Wl,-h,<finallibname>'
- # May need -fPIC
-- CC_SHL='${CC} -fpic'
-+ CC_SHL='${CC} -fPIC'
- #C_LINKPATH_SHL="-Wl,-rpath -Wl,"
- # More recent versions allow multiple args, separated by commas
- C_LINKPATH_SHL="-Wl,-rpath,"
-@@ -233,7 +233,7 @@
+@@ -13174,7 +13174,7 @@
gcc)
# For example, include the libname as ${LIBNAME_SHL}
#C_LINK_SHL='${CC} -shared -Wl,-h,<finallibname>'