summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2007-12-13 22:39:53 +0000
committerJustin Bronder <jsbronder@gentoo.org>2007-12-13 22:39:53 +0000
commit8abe0cfb5a9b105e9cf765534c13df682987255f (patch)
treecd981a84761825b2a9e8e57250cf35ac0a6b5578 /sys-cluster
parentprune old releases and fix dependencies wrt to bug #193497 (diff)
downloadgentoo-2-8abe0cfb5a9b105e9cf765534c13df682987255f.tar.gz
gentoo-2-8abe0cfb5a9b105e9cf765534c13df682987255f.tar.bz2
gentoo-2-8abe0cfb5a9b105e9cf765534c13df682987255f.zip
Minor fixes to sys-cluster/openmpi-1.2.4, thanks to dberkholz for pointing them out.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog6
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.4.ebuild23
2 files changed, 24 insertions, 5 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 0a02142f04d5..6bb79bd76713 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.10 2007/12/13 02:10:15 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.11 2007/12/13 22:39:53 jsbronder Exp $
+
+ 13 Dec 2007; Justin Bronder <jsbronder@gentoo.org> openmpi-1.2.4.ebuild:
+ Minor fixes to sys-cluster/openmpi-1.2.4, thanks to dberkholz for pointing
+ them out.
*openmpi-1.2.4 (13 Dec 2007)
diff --git a/sys-cluster/openmpi/openmpi-1.2.4.ebuild b/sys-cluster/openmpi/openmpi-1.2.4.ebuild
index a0c8e49f3c5c..941ee0c71e7d 100644
--- a/sys-cluster/openmpi/openmpi-1.2.4.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.4.ebuild,v 1.1 2007/12/13 02:10:15 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.4.ebuild,v 1.2 2007/12/13 22:39:53 jsbronder Exp $
inherit eutils multilib flag-o-matic toolchain-funcs fortran
@@ -21,6 +21,21 @@ RDEPEND="pbs? ( sys-cluster/torque )
DEPEND="${RDEPEND}"
pkg_setup() {
+ if use threads; then
+ ewarn
+ ewarn "WARNING: use of threads is still disabled by default in"
+ ewarn "upstream builds."
+ ewarn "You may stop now and set USE=-threads"
+ ewarn
+ epause 5
+ fi
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+
if use fortran; then
FORTRAN="g77 gfortran ifc"
fortran_pkg_setup
@@ -41,7 +56,7 @@ src_compile() {
--with-threads=posix"
fi
- if [[ -n "${FORTRANC}" ]]; then
+ if use fortran; then
if [[ "${FORTRANC}" = "g77" ]]; then
myconf="${myconf} --disable-mpi-f90"
elif [[ "${FORTRANC}" = "gfortran" ]]; then
@@ -58,7 +73,7 @@ src_compile() {
$(use_enable !nocxx mpi-cxx) \
$(use_enable romio romio-io) \
$(use_enable smp smp-locks) \
- $(use_enable heterogeneous heterogeneous) \
+ $(use_enable heterogeneous) \
$(use_with pbs tm /usr/$(get_libdir)/pbs) \
$(use_with slurm) \
$(use_enable ipv6) \
@@ -68,6 +83,6 @@ src_compile() {
}
src_install () {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
dodoc README AUTHORS NEWS VERSION
}