summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2012-09-04 03:35:05 +0000
committerJustin Bronder <jsbronder@gentoo.org>2012-09-04 03:35:05 +0000
commita3c7f664b6fa3f2dbb2e1c55d04ff5ecdfc418d1 (patch)
treefa201caeabb1875267f959be63b927fc542ee1fa /sys-cluster
parentAdd sys-cluster/ganglia-web to match upstream development. Resolves #428776 (diff)
downloadgentoo-2-a3c7f664b6fa3f2dbb2e1c55d04ff5ecdfc418d1.tar.gz
gentoo-2-a3c7f664b6fa3f2dbb2e1c55d04ff5ecdfc418d1.tar.bz2
gentoo-2-a3c7f664b6fa3f2dbb2e1c55d04ff5ecdfc418d1.zip
Bump to 3.3.7. Includes splitting the web interface to sys-cluster/ganglia-web to match upstream. Resolves #380981
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ganglia/ChangeLog8
-rw-r--r--sys-cluster/ganglia/ganglia-3.3.7.ebuild96
2 files changed, 103 insertions, 1 deletions
diff --git a/sys-cluster/ganglia/ChangeLog b/sys-cluster/ganglia/ChangeLog
index e1230f836bd9..2fa9149d0791 100644
--- a/sys-cluster/ganglia/ChangeLog
+++ b/sys-cluster/ganglia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ganglia
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia/ChangeLog,v 1.49 2012/09/02 14:48:51 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia/ChangeLog,v 1.50 2012/09/04 03:35:05 jsbronder Exp $
+
+*ganglia-3.3.7 (04 Sep 2012)
+
+ 04 Sep 2012; Justin Bronder <jsbronder@gentoo.org> +ganglia-3.3.7.ebuild:
+ Bump to 3.3.7. Includes splitting the web interface to
+ sys-cluster/ganglia-web to match upstream. Resolves #380981
02 Sep 2012; Kacper Kowalik <xarthisius@gentoo.org> -ganglia-3.1.2.ebuild,
-ganglia-3.1.7-r2.ebuild, -ganglia-3.1.7-r3.ebuild:
diff --git a/sys-cluster/ganglia/ganglia-3.3.7.ebuild b/sys-cluster/ganglia/ganglia-3.3.7.ebuild
new file mode 100644
index 000000000000..79927ce6ac18
--- /dev/null
+++ b/sys-cluster/ganglia/ganglia-3.3.7.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia/ganglia-3.3.7.ebuild,v 1.1 2012/09/04 03:35:05 jsbronder Exp $
+
+EAPI="3"
+WEBAPP_OPTIONAL="yes"
+
+PYTHON_DEPEND="python? 2"
+
+inherit eutils multilib python
+
+DESCRIPTION="A scalable distributed monitoring system for clusters and grids"
+HOMEPAGE="http://ganglia.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ganglia/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="minimal pcre python examples"
+
+DEPEND="dev-libs/confuse
+ dev-libs/expat
+ >=dev-libs/apr-1.0
+ !dev-db/firebird
+ pcre? ( dev-libs/libpcre )"
+
+RDEPEND="
+ ${DEPEND}
+ !minimal? ( net-analyzer/rrdtool )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Disable modpython by default (#358359)
+ sed -i '/ *params/N;s,\( *\)\(params = "[^"]*"\),\1\2\n\1enabled = no,' \
+ gmond/modules/conf.d/modpython.conf.in || die
+}
+
+src_configure() {
+ econf \
+ --enable-gexec \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ $(use_enable python) \
+ $(use_with pcre libpcre) \
+ $(use_with !minimal gmetad)
+}
+
+src_install() {
+ local exdir=/usr/share/doc/${P}
+
+ emake DESTDIR="${D}" install || die
+
+ newinitd "${FILESDIR}"/gmond.rc-2 gmond
+ doman {mans/*.1,gmond/*.5} || die "Failed to install manpages"
+ dodoc AUTHORS INSTALL NEWS README || die
+
+ dodir /etc/ganglia/conf.d
+ use python && dodir /usr/$(get_libdir)/ganglia/python_modules
+ gmond/gmond -t > "${ED}"/etc/ganglia/gmond.conf
+
+ if use examples; then
+ insinto ${exdir}/cmod-examples
+ doins gmond/modules/example/*.c
+ if use python; then
+ # Installing as an examples per upstream.
+ insinto ${exdir}/pymod-examples
+ doins gmond/python_modules/*/*.py
+ insinto ${exdir}/pymod-examples/conf.d
+ doins gmond/python_modules/conf.d/*.pyconf
+ fi
+ fi
+
+ if ! use minimal; then
+ rnsinto /etc/ganglia
+ doins gmetad/gmetad.conf
+ doman mans/gmetad.1
+
+ newinitd "${FILESDIR}"/gmetad.rc-2 gmetad
+ keepdir /var/lib/ganglia/rrds
+ fowners nobody:nobody /var/lib/ganglia/rrds
+ fi
+}
+
+pkg_postinst() {
+ elog "A default configuration file for gmond has been generated"
+ elog "for you as a template by running:"
+ elog " /usr/sbin/gmond -t > /etc/ganglia/gmond.conf"
+
+ elog "The web frontend for Ganglia has been split off. Emerge"
+ elog "sys-cluster/ganglia-web if you need it."
+}