summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-03-26 00:48:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-03-26 00:48:55 +0000
commitf57069766372fb193c5ac1259201571e52708172 (patch)
treec4c669be6099d217c7212f0eaefb95d3235b19a8 /sys-devel/autoconf
parentstamp fix (diff)
downloadgentoo-2-f57069766372fb193c5ac1259201571e52708172.tar.gz
gentoo-2-f57069766372fb193c5ac1259201571e52708172.tar.bz2
gentoo-2-f57069766372fb193c5ac1259201571e52708172.zip
add more compadible version
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/autoconf-2.52d.ebuild121
-rw-r--r--sys-devel/autoconf/autoconf-2.52i.ebuild121
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.52d2
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.52i2
4 files changed, 246 insertions, 0 deletions
diff --git a/sys-devel/autoconf/autoconf-2.52d.ebuild b/sys-devel/autoconf/autoconf-2.52d.ebuild
new file mode 100644
index 000000000000..4f9b382c3028
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.52d.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.52d.ebuild,v 1.1 2002/03/26 00:48:55 azarah Exp $
+
+OLD_PV=2.13
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+DEPEND=">=sys-devel/m4-1.4p
+ sys-devel/perl"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${OLD_S}
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure-gentoo.diff || die
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff || die
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${OLD_P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ datadir=/usr/share/${P} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-2.5x
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+ mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PF}/${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share/${OLD_P} \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${PF}/${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/autoconf-2.52i.ebuild b/sys-devel/autoconf/autoconf-2.52i.ebuild
new file mode 100644
index 000000000000..9a99e8714746
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.52i.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.52i.ebuild,v 1.1 2002/03/26 00:48:55 azarah Exp $
+
+OLD_PV=2.13
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+DEPEND=">=sys-devel/m4-1.4p
+ sys-devel/perl"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${OLD_S}
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure-gentoo.diff || die
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff || die
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${OLD_P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ datadir=/usr/share/${P} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-2.5x
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+ mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PF}/${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share/${OLD_P} \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${PF}/${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.52d b/sys-devel/autoconf/files/digest-autoconf-2.52d
new file mode 100644
index 000000000000..fdbf6fcd2ead
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.52d
@@ -0,0 +1,2 @@
+MD5 e8be7e4bb13a7ad33156ad15029814ba autoconf-2.52d.tar.bz2 698820
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.52i b/sys-devel/autoconf/files/digest-autoconf-2.52i
new file mode 100644
index 000000000000..88b00436fa4e
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.52i
@@ -0,0 +1,2 @@
+MD5 77d0b398554eec369fd58527a9953c99 autoconf-2.52i.tar.bz2 753029
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844