summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-15 04:27:29 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-15 04:27:29 +0000
commit70bc2c4a894f38a6cdd78ec60d3d7d395c28f42e (patch)
treee4325964681b4a179890934b091a39a173e2f05c /sys-devel/automake
parentBuild the lib & bin in diff subdirs so we can avoid the clean step. (diff)
downloadgentoo-2-70bc2c4a894f38a6cdd78ec60d3d7d395c28f42e.tar.gz
gentoo-2-70bc2c4a894f38a6cdd78ec60d3d7d395c28f42e.tar.bz2
gentoo-2-70bc2c4a894f38a6cdd78ec60d3d7d395c28f42e.zip
Old.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/ChangeLog6
-rw-r--r--sys-devel/automake/automake-1.13.1.ebuild96
-rw-r--r--sys-devel/automake/automake-1.13.2.ebuild96
-rw-r--r--sys-devel/automake/automake-1.13.3.ebuild96
-rw-r--r--sys-devel/automake/automake-1.14.ebuild99
5 files changed, 5 insertions, 388 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 0348b0b76bc3..f84c4092f7d8 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.212 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.213 2014/11/15 04:27:29 vapier Exp $
+
+ 15 Nov 2014; Mike Frysinger <vapier@gentoo.org> -automake-1.13.1.ebuild,
+ -automake-1.13.2.ebuild, -automake-1.13.3.ebuild, -automake-1.14.ebuild:
+ Old.
17 Jan 2014; Mike Frysinger <vapier@gentoo.org> automake-1.10.3.ebuild,
automake-1.11.6.ebuild, automake-1.12.6.ebuild, automake-1.13.4.ebuild,
diff --git a/sys-devel/automake/automake-1.13.1.ebuild b/sys-devel/automake/automake-1.13.1.ebuild
deleted file mode 100644
index 823e2fa11c0a..000000000000
--- a/sys-devel/automake/automake-1.13.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.13.1.ebuild,v 1.7 2014/01/16 06:25:07 vapier Exp $
-
-inherit eutils versionator unpacker
-
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-fi
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://www.gnu.org/software/automake/"
-
-LICENSE="GPL-2"
-# Use Gentoo versioning for slotting.
-SLOT="${PV:0:4}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
- export WANT_AUTOCONF=2.5
- epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
-}
-
-src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
-}
-
-# slot the info pages. do this w/out munging the source so we don't have
-# to depend on texinfo to regen things. #464146 (among others)
-slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
- rm -f dir
-
- # Rewrite all the references to other pages.
- # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
- # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
- local p pages=( *.info ) args=()
- for p in "${pages[@]/%.info}" ; do
- args+=(
- -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
- -e "s:(${p}):(${p}-${SLOT}):g"
- )
- done
- sed -i "${args[@]}" * || die
-
- # Rewrite all the file references, and rename them in the process.
- local f d
- for f in * ; do
- d=${f/.info/-${SLOT}.info}
- mv "${f}" "${d}" || die
- sed -i -e "s:${f}:${d}:g" * || die
- done
-
- popd >/dev/null
-}
-
-src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
- slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.13.2.ebuild b/sys-devel/automake/automake-1.13.2.ebuild
deleted file mode 100644
index ed889fbe733d..000000000000
--- a/sys-devel/automake/automake-1.13.2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.13.2.ebuild,v 1.3 2014/01/16 06:25:07 vapier Exp $
-
-inherit eutils versionator unpacker
-
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-fi
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://www.gnu.org/software/automake/"
-
-LICENSE="GPL-2"
-# Use Gentoo versioning for slotting.
-SLOT="${PV:0:4}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
- export WANT_AUTOCONF=2.5
- epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
-}
-
-src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
-}
-
-# slot the info pages. do this w/out munging the source so we don't have
-# to depend on texinfo to regen things. #464146 (among others)
-slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
- rm -f dir
-
- # Rewrite all the references to other pages.
- # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
- # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
- local p pages=( *.info ) args=()
- for p in "${pages[@]/%.info}" ; do
- args+=(
- -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
- -e "s:(${p}):(${p}-${SLOT}):g"
- )
- done
- sed -i "${args[@]}" * || die
-
- # Rewrite all the file references, and rename them in the process.
- local f d
- for f in * ; do
- d=${f/.info/-${SLOT}.info}
- mv "${f}" "${d}" || die
- sed -i -e "s:${f}:${d}:g" * || die
- done
-
- popd >/dev/null
-}
-
-src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
- slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.13.3.ebuild b/sys-devel/automake/automake-1.13.3.ebuild
deleted file mode 100644
index 530d449953d6..000000000000
--- a/sys-devel/automake/automake-1.13.3.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.13.3.ebuild,v 1.3 2014/01/16 06:25:07 vapier Exp $
-
-inherit eutils versionator unpacker
-
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-fi
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://www.gnu.org/software/automake/"
-
-LICENSE="GPL-2"
-# Use Gentoo versioning for slotting.
-SLOT="${PV:0:4}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
- export WANT_AUTOCONF=2.5
- epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
-}
-
-src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
-}
-
-# slot the info pages. do this w/out munging the source so we don't have
-# to depend on texinfo to regen things. #464146 (among others)
-slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
- rm -f dir
-
- # Rewrite all the references to other pages.
- # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
- # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
- local p pages=( *.info ) args=()
- for p in "${pages[@]/%.info}" ; do
- args+=(
- -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
- -e "s:(${p}):(${p}-${SLOT}):g"
- )
- done
- sed -i "${args[@]}" * || die
-
- # Rewrite all the file references, and rename them in the process.
- local f d
- for f in * ; do
- d=${f/.info/-${SLOT}.info}
- mv "${f}" "${d}" || die
- sed -i -e "s:${f}:${d}:g" * || die
- done
-
- popd >/dev/null
-}
-
-src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
- slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.14.ebuild b/sys-devel/automake/automake-1.14.ebuild
deleted file mode 100644
index aa6d6d3d778b..000000000000
--- a/sys-devel/automake/automake-1.14.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.14.ebuild,v 1.3 2014/01/17 04:23:15 vapier Exp $
-
-inherit eutils versionator unpacker
-
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-fi
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://www.gnu.org/software/automake/"
-
-LICENSE="GPL-2"
-# Use Gentoo versioning for slotting.
-SLOT="${PV:0:4}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
- export WANT_AUTOCONF=2.5
-}
-
-src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
-}
-
-src_test() {
- emake check || die
-}
-
-# slot the info pages. do this w/out munging the source so we don't have
-# to depend on texinfo to regen things. #464146 (among others)
-slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
- rm -f dir
-
- # Rewrite all the references to other pages.
- # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
- # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
- local p pages=( *.info ) args=()
- for p in "${pages[@]/%.info}" ; do
- args+=(
- -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
- -e "s:(${p}):(${p}-${SLOT}):g"
- )
- done
- sed -i "${args[@]}" * || die
-
- # Rewrite all the file references, and rename them in the process.
- local f d
- for f in * ; do
- d=${f/.info/-${SLOT}.info}
- mv "${f}" "${d}" || die
- sed -i -e "s:${f}:${d}:g" * || die
- done
-
- popd >/dev/null
-}
-
-src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
- slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}