summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-16 02:23:49 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-16 02:23:49 +0000
commit642bf0589ec431b791dfd8f3adbfd0932ee3c82f (patch)
tree725e6326c72f7df705c83864c4d6af9bd09e5467 /sys-devel/bison
parentStable on x86, bug #53544 (Manifest recommit) (diff)
downloadgentoo-2-642bf0589ec431b791dfd8f3adbfd0932ee3c82f.tar.gz
gentoo-2-642bf0589ec431b791dfd8f3adbfd0932ee3c82f.tar.bz2
gentoo-2-642bf0589ec431b791dfd8f3adbfd0932ee3c82f.zip
uclibc fixes thanks to Peter S. Mazinger <ps.m@gmx.net>
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog5
-rw-r--r--sys-devel/bison/bison-1.875.ebuild12
2 files changed, 12 insertions, 5 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index c0ca1fa988c4..042ff82246a1 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.26 2004/02/06 20:39:55 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.27 2004/06/16 02:23:49 dragonheart Exp $
+
+ 16 Jun 2004; Daniel Black <dragonheart@gentoo.org> bison-1.875.ebuild:
+ uclibc fixes thanks to Peter S. Mazinger <ps.m@gmx.net>
06 Feb 2004; <gustavoz@gentoo.org> bison-1.875.ebuild:
stable on sparc
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index 231f9fda9e1c..86e72494e657 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.18 2004/04/27 12:07:03 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.19 2004/06/16 02:23:49 dragonheart Exp $
inherit gcc flag-o-matic eutils
@@ -11,11 +11,13 @@ SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE="nls static"
+IUSE="nls static uclibc"
DEPEND="sys-devel/m4
nls? ( sys-devel/gettext )"
+use uclibc && PROVIDE="dev-util/yacc"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -33,7 +35,7 @@ src_compile() {
# Bug 29017 says that bison has compile-time issues with
# -march=k6* prior to 3.4CVS. Use -march=i586 instead
# (04 Feb 2004 agriffis)
- if [ $(gcc-major-version) == 3 ] && [ $(gcc-minor-version) < 4 ] ; then
+ if [ "`gcc-major-version`" -eq "3" -a "`gcc-minor-version`" -lt "4" ] ; then
replace-cpu-flags i586 k6 k6-1 k6-2
fi
@@ -54,7 +56,9 @@ src_install() {
install || die
# This one is installed by dev-util/yacc
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
+ if ! use uclibc; then
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
+ fi
# We do not need this.
rm -f ${D}/usr/lib/liby.a