summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-12 19:33:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-12 19:33:50 +0000
commit51bd2013a0b76b66facbb11d2ef4331f67d01b27 (patch)
tree22571b2473b801c660822ebb2e0e43734e298561 /sys-devel/crossdev
parenthppa/ia64 stable (diff)
downloadgentoo-2-51bd2013a0b76b66facbb11d2ef4331f67d01b27.tar.gz
gentoo-2-51bd2013a0b76b66facbb11d2ef4331f67d01b27.tar.bz2
gentoo-2-51bd2013a0b76b66facbb11d2ef4331f67d01b27.zip
Add a --stage0 (for binutils), use a diff PORTAGE_TMPDIR, and make sure that the diff PKGDIR is actually used.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/crossdev-0.9.1-r2.ebuild (renamed from sys-devel/crossdev/crossdev-0.9.1-r1.ebuild)2
-rwxr-xr-xsys-devel/crossdev/files/crossdev13
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.1-r2 (renamed from sys-devel/crossdev/files/digest-crossdev-0.9.1-r1)0
4 files changed, 19 insertions, 5 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 339e9a62d395..a7cc7395a47b 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/crossdev
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.12 2005/03/10 22:49:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.13 2005/03/12 19:33:50 vapier Exp $
+
+*crossdev-0.9.1-r2 (12 Mar 2005)
+
+ 12 Mar 2005; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ -crossdev-0.9.1-r1.ebuild, +crossdev-0.9.1-r2.ebuild:
+ Add a --stage0 (for binutils), use a diff PORTAGE_TMPDIR, and make sure that
+ the diff PKGDIR is actually used.
*crossdev-0.9.1-r1 (10 Mar 2005)
diff --git a/sys-devel/crossdev/crossdev-0.9.1-r1.ebuild b/sys-devel/crossdev/crossdev-0.9.1-r2.ebuild
index 5ec955c808ca..caa01e397e6d 100644
--- a/sys-devel/crossdev/crossdev-0.9.1-r1.ebuild
+++ b/sys-devel/crossdev/crossdev-0.9.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.1-r1.ebuild,v 1.1 2005/03/10 22:49:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.1-r2.ebuild,v 1.1 2005/03/12 19:33:50 vapier Exp $
DESCRIPTION="Gentoo Cross-toolchain generator"
HOMEPAGE="http://www.gentoo.org/"
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index f4cf3e6e6e0f..37ef24a659c3 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.9 2005/03/10 22:49:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.10 2005/03/12 19:33:50 vapier Exp $
source /sbin/functions.sh || exit 1
die() {
@@ -28,6 +28,7 @@ ${GOOD}Options${NORMAL}:
${GOOD}-C, --clean${NORMAL} target Uninstall specified target
${GOOD}-a, -b, -p, -v${NORMAL} Options to pass to emerge (see emerge(1))
+ ${GOOD}-s0, --stage0${NORMAL} Build just binutils
${GOOD}-s1, --stage1${NORMAL} Build a C compiler (no libc/C++)
${GOOD}-s2, --stage2${NORMAL} Build a C compiler & libc (no C++)
${GOOD}-s3, --stage3${NORMAL} Build a C/C++ compiler & libc [default]
@@ -90,8 +91,10 @@ setup_portage_vars() {
PORTDIR=$(portageq envvar PORTDIR)
PORT_LOGDIR=$(portageq envvar PORT_LOGDIR)
PORT_LOGDIR=${PORT_LOGDIR:-/var/log/portage}
- PKGDIR=$(portageq envvar PKGDIR)/cross/${CTARGET}
+ export PKGDIR=$(portageq envvar PKGDIR)/cross/${CTARGET}
+ export PORTAGE_TMPDIR=$(portageq envvar PORTAGE_TMPDIR)/cross/${CTARGET}
[[ ! -d ${PORT_LOGDIR} ]] && mkdir -p ${PORT_LOGDIR}
+ [[ ! -d ${PORTAGE_TMPDIR} ]] && mkdir -p ${PORTAGE_TMPDIR}
}
uninstall() {
@@ -142,6 +145,7 @@ TARCH=
HARCH=$(env -uARCH portageq envvar ARCH)
CTARGET=
STAGE=4
+STAGE_DISP=( "binutils" "gcc C-only" "libc" "gcc C/C++" )
BVER="[latest]" ; BUSE=""
GVER="[latest]" ; GUSE=""
KVER="[latest]" ; KUSE=""
@@ -191,9 +195,10 @@ hr
einfo "Host Portage ARCH: ${HARCH}"
einfo "Target Portage ARCH: ${TARCH}"
einfo "Target System: ${CTARGET}"
-einfo "Stage: ${STAGE}"
+einfo "Stage: ${STAGE} (${STAGE_DISP[${STAGE}]})"
echo
einfo "binutils: ${BVER}"
+[[ ${STAGE} -gt 0 ]] && \
einfo "gcc: ${GVER}"
[[ ${STAGE} -gt 1 ]] && \
einfo "linux-headers: ${KVER}" && \
@@ -202,6 +207,7 @@ echo
einfo "PORTDIR_OVERLAY: ${PORTDIR_OVERLAY}"
einfo "PORT_LOGDIR: ${PORT_LOGDIR}"
einfo "PKGDIR: ${PKGDIR}"
+einfo "PORTAGE_TMPDIR: ${PORTAGE_TMPDIR}"
hr
) >& ${PORT_LOGDIR}/cross-${CTARGET}-info.log
cat ${PORT_LOGDIR}/cross-${CTARGET}-info.log
@@ -266,6 +272,7 @@ doemerge() {
EOPTS="${UOPTS} -u --nodeps"
doemerge binutils
+[[ ${STAGE} -gt 0 ]] || exit 0
USE="-boundschecking -fortran -gcj -objc nocxx -static" \
doemerge gcc gcc-stage1
[[ ${STAGE} -gt 1 ]] || exit 0
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.1-r1 b/sys-devel/crossdev/files/digest-crossdev-0.9.1-r2
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/crossdev/files/digest-crossdev-0.9.1-r1
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.1-r2