summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-29 22:25:33 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-29 22:25:33 +0000
commit5f517ed9aabb5e8453246c332e9b887e975ff324 (patch)
treeb9052a6f77d8dde0bc0b40a4728fd8bd2e23de6a /sys-devel/crossdev
parentRevbump to use the correct location for ghostscript fonts used by freetype fo... (diff)
downloadgentoo-2-5f517ed9aabb5e8453246c332e9b887e975ff324.tar.gz
gentoo-2-5f517ed9aabb5e8453246c332e9b887e975ff324.tar.bz2
gentoo-2-5f517ed9aabb5e8453246c332e9b887e975ff324.zip
Version bump.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog7
-rw-r--r--sys-devel/crossdev/crossdev-20120229.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index c08155e0613e..8161fe00cfae 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.91 2012/02/28 18:23:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.92 2012/02/29 22:25:33 vapier Exp $
+
+*crossdev-20120229 (29 Feb 2012)
+
+ 29 Feb 2012; Mike Frysinger <vapier@gentoo.org> +crossdev-20120229.ebuild:
+ Version bump.
*crossdev-20120228 (28 Feb 2012)
diff --git a/sys-devel/crossdev/crossdev-20120229.ebuild b/sys-devel/crossdev/crossdev-20120229.ebuild
new file mode 100644
index 000000000000..ee357a1d53f5
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20120229.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20120229.ebuild,v 1.1 2012/02/29 22:25:33 vapier Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}