summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-12 07:00:10 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-12 07:00:10 +0000
commita0fd918d38cbee7df3b43dee4d64febccff3bd28 (patch)
tree40f702b3bef32bb8564c27f59240538ee96826e2 /sys-devel/gcc-config
parentold (diff)
downloadgentoo-2-a0fd918d38cbee7df3b43dee4d64febccff3bd28.tar.gz
gentoo-2-a0fd918d38cbee7df3b43dee4d64febccff3bd28.tar.bz2
gentoo-2-a0fd918d38cbee7df3b43dee4d64febccff3bd28.zip
Add wrappers for gcjh, gfortran, and the D language #157694 by Philipp Kirchner.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/ChangeLog9
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.15-r10
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.159
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.15-r1.ebuild51
4 files changed, 64 insertions, 5 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 8756aec12b64..530fd6d2a340 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.142 2007/01/27 19:26:41 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.143 2007/03/12 07:00:10 vapier Exp $
+
+*gcc-config-1.3.15-r1 (12 Mar 2007)
+
+ 12 Mar 2007; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.15,
+ +gcc-config-1.3.15-r1.ebuild:
+ Add wrappers for gcjh, gfortran, and the D language #157694 by Philipp
+ Kirchner.
27 Jan 2007; Alexander H. Færøy <eroyf@gentoo.org>
gcc-config-1.3.14.ebuild:
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.15-r1 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.15-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.15-r1
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.15 b/sys-devel/gcc-config/files/gcc-config-1.3.15
index f470948c99d0..51dd400747ac 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.15
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.15
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.15,v 1.2 2006/12/16 19:36:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.15,v 1.3 2007/03/12 07:00:10 vapier Exp $
trap ":" INT QUIT TSTP
@@ -295,9 +295,10 @@ switch_profile() {
done
# Update the wrappers for this profile
- local native="gcc cpp cc c++ g++ f77 g77 gcj"
- is_cross_compiler && native=""
- for x in ${native} ${CTARGET}-{cpp,gcc,c++,g++,f77,g77,gcj} ; do
+ for x in {,${CTARGET}}-{cpp,cc,gcc,c++,g++,f77,g77,gcj,gcjh,gfortran,gdc,gdmd} ; do
+ # Obviously don't want to touch native stuff for cross-compilers
+ [[ ${x} != ${CTARGET}-* ]] && is_cross_compiler && continue
+
# Make sure we have no stale wrappers
${RM} -f "${ROOT}/usr/bin/${x}"
[[ ${x:${#x}-3} == "gcc" || ${x:${#x}-3} == "g++" ]] \
diff --git a/sys-devel/gcc-config/gcc-config-1.3.15-r1.ebuild b/sys-devel/gcc-config/gcc-config-1.3.15-r1.ebuild
new file mode 100644
index 000000000000..85ae64587ff6
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.3.15-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.15-r1.ebuild,v 1.1 2007/03/12 07:00:10 vapier Exp $
+
+inherit toolchain-funcs multilib
+
+# Version of .c wrapper to use
+W_VER="1.4.7"
+
+DESCRIPTION="Utility to change the gcc compiler being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!app-admin/eselect-compiler"
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) -O2 -Wall -o wrapper \
+ "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
+}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
+ sed -i \
+ -e "s:PORTAGE-VERSION:${PVR}:g" \
+ -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${D}"/usr/bin/${PN}
+
+ exeinto /usr/$(get_libdir)/misc
+ newexe wrapper gcc-config || die "install wrapper"
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ if gcc-config --get-current-profile &>/dev/null ; then
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
+ [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
+ [[ ${ROOT} = "/" ]] && gcc-config $(/usr/bin/gcc-config --get-current-profile)
+ fi
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config
+}