summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-11-19 03:17:51 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-11-19 03:17:51 +0000
commit7a4c5c7049355197b26a303bae90bbe2896baacd (patch)
tree9b8883ad18e662f68724dd6df076440fd59f3eca /sys-devel/gcc/gcc-3.3.2-r2.ebuild
parentversion bump to 0.6.4 (diff)
downloadgentoo-2-7a4c5c7049355197b26a303bae90bbe2896baacd.tar.gz
gentoo-2-7a4c5c7049355197b26a303bae90bbe2896baacd.tar.bz2
gentoo-2-7a4c5c7049355197b26a303bae90bbe2896baacd.zip
Added --enable-sjlj-exceptions to on hppa.
Diffstat (limited to 'sys-devel/gcc/gcc-3.3.2-r2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-3.3.2-r2.ebuild b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
index b7c38563d9d1..8217a603caa0 100644
--- a/sys-devel/gcc/gcc-3.3.2-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r2.ebuild,v 1.4 2003/11/02 10:44:52 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r2.ebuild,v 1.5 2003/11/19 03:17:42 gmsoft Exp $
IUSE="static nls bootstrap java build X multilib"
@@ -289,6 +289,9 @@ src_compile() {
myconf="${myconf} --disable-multilib"
fi
+ #Fix linking problem with c++ apps which where linked agains a 3.2.2 libgcc
+ [ "${ARCH}" = "hppa" ] && myconf="${myconf} --enable-sjlj-exceptions"
+
# In general gcc does not like optimization, and add -O2 where
# it is safe. This is especially true for gcc-3.3 ...
export CFLAGS="${CFLAGS/-O?/-O2}"