summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-06-24 09:40:20 +0000
committerFabian Groffen <grobian@gentoo.org>2009-06-24 09:40:20 +0000
commit2c96bb1017cd14913548ef1726f64656196285b1 (patch)
tree0e22ae636d199c695b3c02cae73850a6a90b5ea7 /sys-devel/gdb-apple
parentVersion bump (diff)
downloadgentoo-2-2c96bb1017cd14913548ef1726f64656196285b1.tar.gz
gentoo-2-2c96bb1017cd14913548ef1726f64656196285b1.tar.bz2
gentoo-2-2c96bb1017cd14913548ef1726f64656196285b1.zip
Add compile fix for x64-macos
(Portage version: 2.2.00.13683-prefix/cvs/SunOS i386)
Diffstat (limited to 'sys-devel/gdb-apple')
-rw-r--r--sys-devel/gdb-apple/ChangeLog7
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-962-darwin64.patch17
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-962-demangle.patch22
-rw-r--r--sys-devel/gdb-apple/gdb-apple-966.ebuild6
4 files changed, 49 insertions, 3 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index 3b0b7a08adef..6195024c0b33 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.1 2009/06/21 10:38:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.2 2009/06/24 09:40:20 grobian Exp $
+
+ 24 Jun 2009; Fabian Groffen <grobian@gentoo.org>
+ +files/gdb-apple-962-darwin64.patch, +files/gdb-apple-962-demangle.patch,
+ gdb-apple-966.ebuild:
+ Add compile fix for x64-macos
*gdb-apple-966 (20 Jun 2009)
diff --git a/sys-devel/gdb-apple/files/gdb-apple-962-darwin64.patch b/sys-devel/gdb-apple/files/gdb-apple-962-darwin64.patch
new file mode 100644
index 000000000000..4417cee76e4d
--- /dev/null
+++ b/sys-devel/gdb-apple/files/gdb-apple-962-darwin64.patch
@@ -0,0 +1,17 @@
+* todo: extend for powerpc64 also
+
+--- src/bfd/config.bfd.orig 2009-06-23 11:05:43 +0200
++++ src/bfd/config.bfd 2009-06-23 11:05:47 +0200
+@@ -500,6 +500,12 @@
+ targ_archs="bfd_i386_arch bfd_powerpc_arch bfd_rs6000_arch"
+ targ_underscore=yes
+ ;;
++ x86_64-*-darwin*)
++ targ_defvec=mach_o_le_vec
++ targ_selvecs="mach_o_le_vec mach_o_be_vec mach_o_fat_vec pef_vec pef_xlib_vec sym_vec"
++ targ_archs="bfd_i386_arch bfd_powerpc_arch bfd_rs6000_arch"
++ targ_underscore=yes
++ ;;
+ i[3-7]86-sequent-bsd*)
+ targ_defvec=i386dynix_vec
+ targ_underscore=yes
diff --git a/sys-devel/gdb-apple/files/gdb-apple-962-demangle.patch b/sys-devel/gdb-apple/files/gdb-apple-962-demangle.patch
new file mode 100644
index 000000000000..a302ce56ec91
--- /dev/null
+++ b/sys-devel/gdb-apple/files/gdb-apple-962-demangle.patch
@@ -0,0 +1,22 @@
+in 32-bits mode this goes /just/ right, in 64-bits mode Portage aborts
+because objc_demangle is implicitly turned into a pointer
+
+--- src/gdb/maint.c.orig 2009-06-23 11:12:15 +0200
++++ src/gdb/maint.c 2009-06-23 11:19:58 +0200
+@@ -31,6 +31,7 @@
+ #include "symtab.h"
+ #include "gdbtypes.h"
+ #include "demangle.h"
++#include "objc-lang.h"
+ #include "gdbcore.h"
+ #include "expression.h" /* For language.h */
+ #include "language.h"
+@@ -167,7 +168,7 @@
+ switch (current_language->la_language)
+ {
+ case language_objc:
+- demangled = objc_demangle (args);
++ demangled = objc_demangle (args, 0);
+ break;
+ case language_objcplus:
+ case language_cplus:
diff --git a/sys-devel/gdb-apple/gdb-apple-966.ebuild b/sys-devel/gdb-apple/gdb-apple-966.ebuild
index 806549b850db..df38945f1705 100644
--- a/sys-devel/gdb-apple/gdb-apple-966.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-966.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.1 2009/06/21 10:38:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.2 2009/06/24 09:40:20 grobian Exp $
inherit eutils flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.t
LICENSE="APSL-2 GPL-2"
SLOT="0"
-KEYWORDS="~ppc-macos ~x86-macos"
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="nls"
@@ -29,6 +29,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
epatch "${FILESDIR}"/${PN}-962-darwin8.patch
+ epatch "${FILESDIR}"/${PN}-962-darwin64.patch
+ epatch "${FILESDIR}"/${PN}-962-demangle.patch
# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh