summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-09-03 14:30:33 +0000
committerFabian Groffen <grobian@gentoo.org>2011-09-03 14:30:33 +0000
commit88ea45d1aef75e9bad8566755bd05a19de3a1166 (patch)
tree2f3f88f9e9fdad20daaf76ca0704fd7997ca3eae /sys-devel/gdb-apple
parentarm/ia64/s390/sh/sparc/x86 stable wrt #380475 (diff)
downloadgentoo-2-88ea45d1aef75e9bad8566755bd05a19de3a1166.tar.gz
gentoo-2-88ea45d1aef75e9bad8566755bd05a19de3a1166.tar.bz2
gentoo-2-88ea45d1aef75e9bad8566755bd05a19de3a1166.zip
Version bump to version from Developer Tools 4.1
(Portage version: 2.2.01.19120-prefix/cvs/Darwin i386)
Diffstat (limited to 'sys-devel/gdb-apple')
-rw-r--r--sys-devel/gdb-apple/ChangeLog7
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1705.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index bc7233def036..91bff06b936c 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.12 2011/07/12 05:49:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.13 2011/09/03 14:30:33 grobian Exp $
+
+*gdb-apple-1705 (03 Sep 2011)
+
+ 03 Sep 2011; Fabian Groffen <grobian@gentoo.org> +gdb-apple-1705.ebuild:
+ Version bump to version from Developer Tools 4.1
12 Jul 2011; Fabian Groffen <grobian@gentoo.org>
files/gdb-apple-1518-darwin8-9.patch, files/gdb-apple-1518-darwin8.patch:
diff --git a/sys-devel/gdb-apple/gdb-apple-1705.ebuild b/sys-devel/gdb-apple/gdb-apple-1705.ebuild
new file mode 100644
index 000000000000..55d74ba58566
--- /dev/null
+++ b/sys-devel/gdb-apple/gdb-apple-1705.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1705.ebuild,v 1.1 2011/09/03 14:30:33 grobian Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic
+
+APPLE_PV=${PV}
+DESCRIPTION="Apple branch of the GNU Debugger, Developer Tools 4.1"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${APPLE_PV}.tar.gz"
+
+LICENSE="APSL-2 GPL-2"
+SLOT="0"
+
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ =dev-db/sqlite-3*"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/gdb-${APPLE_PV}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
+ epatch "${FILESDIR}"/${PN}-768-texinfo.patch
+ epatch "${FILESDIR}"/${PN}-1518-darwin8-9.patch
+ [[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1518-darwin8.patch
+}
+
+src_configure() {
+ replace-flags -O? -O2
+ econf \
+ --disable-werror \
+ --disable-debug-symbols-framework \
+ $(use_enable nls) \
+ || die
+}
+
+src_compile() {
+ # unable to work around parallel make issue
+ emake -j2 || die
+}
+
+src_install() {
+ emake -j2 DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
+ rm -R "${D}"/nukeme || die
+ rm -Rf "${ED}"/usr/${CHOST} || die
+ mv "${ED}"/usr/bin/gdb ${ED}/
+ rm -f "${ED}"/usr/bin/*
+ mv "${ED}"/gdb "${ED}"/usr/bin/
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
+ ewarn "Due to increased security measures in 10.5 and up, gdb is"
+ ewarn "not able to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
+}