summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-22 04:02:43 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-22 04:02:43 +0000
commit64dda2342944c684251948423cbd1e76e5d14177 (patch)
tree19857c866a315cb0f1097315a751b4a90c805186 /sys-devel/gdb
parentadd missing metadata.xml, version bump for bug # 80848 (diff)
downloadgentoo-2-64dda2342944c684251948423cbd1e76e5d14177.tar.gz
gentoo-2-64dda2342944c684251948423cbd1e76e5d14177.tar.bz2
gentoo-2-64dda2342944c684251948423cbd1e76e5d14177.zip
Fix issues with funky locales #125264 by J.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/ChangeLog6
-rw-r--r--sys-devel/gdb/files/gdb-6.5-locale.patch57
-rw-r--r--sys-devel/gdb/gdb-6.5.ebuild3
3 files changed, 64 insertions, 2 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 97127935b8b4..b24222c17b55 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.93 2006/06/22 00:38:43 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.94 2006/06/22 04:02:43 vapier Exp $
+
+ 22 Jun 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/gdb-6.5-locale.patch, gdb-6.5.ebuild:
+ Fix issues with funky locales #125264 by J.
*gdb-6.5-r1 (21 Jun 2006)
diff --git a/sys-devel/gdb/files/gdb-6.5-locale.patch b/sys-devel/gdb/files/gdb-6.5-locale.patch
new file mode 100644
index 000000000000..c50913169e79
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-6.5-locale.patch
@@ -0,0 +1,57 @@
+2006-06-21 Mike Frysinger <vapier@gentoo.org>:
+
+ * Makefile.in (init.c) [LANG, LC_ALL]: Set to `c'.
+ * gdb_indent.sh, gdb_mbuild.sh, observer.sh: Likewise
+
+--- gdb/Makefile.in
++++ gdb/Makefile.in
+@@ -1154,6 +1154,8 @@ init.c: $(INIT_FILES)
+ @rm -f init.c-tmp init.l-tmp
+ @touch init.c-tmp
+ @echo gdbtypes > init.l-tmp
++ LANG=c ; export LANG ; \
++ LC_ALL=c ; export LC_ALL ; \
+ @-echo $(INIT_FILES) | \
+ tr ' ' '\012' | \
+ sed \
+--- gdb/gdb_indent.sh
++++ gdb/gdb_indent.sh
+@@ -3,6 +3,11 @@
+ # Try to find a GNU indent. There could be a BSD indent in front of a
+ # GNU gindent so when indent is found, keep looking.
+
++# Make certain that the script is running in an internationalized
++# environment.
++LANG=c ; export LANG
++LC_ALL=c ; export LC_ALL
++
+ gindent=
+ indent=
+ paths=`echo $PATH | sed \
+--- gdb/gdb_mbuild.sh
++++ gdb/gdb_mbuild.sh
+@@ -22,6 +22,11 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor,
+ # Boston, MA 02111-1301, USA
+
++# Make certain that the script is running in an internationalized
++# environment.
++LANG=c ; export LANG
++LC_ALL=c ; export LC_ALL
++
+ usage()
+ {
+ cat <<EOF
+--- gdb/observer.sh
++++ gdb/observer.sh
+@@ -1,5 +1,10 @@
+ #!/bin/sh -e
+
++# Make certain that the script is running in an internationalized
++# environment.
++LANG=c ; export LANG
++LC_ALL=c ; export LC_ALL
++
+ if test $# -ne 3
+ then
+ echo "Usage: $0 <h|inc> <observer.texi> <observer.out>" 1>&2
diff --git a/sys-devel/gdb/gdb-6.5.ebuild b/sys-devel/gdb/gdb-6.5.ebuild
index 06049b18fa4f..676cf62c1322 100644
--- a/sys-devel/gdb/gdb-6.5.ebuild
+++ b/sys-devel/gdb/gdb-6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.5.ebuild,v 1.1 2006/06/21 17:38:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.5.ebuild,v 1.2 2006/06/22 04:02:43 vapier Exp $
inherit flag-o-matic eutils
@@ -51,6 +51,7 @@ src_unpack() {
fi
epatch "${FILESDIR}"/gdb-configure-LANG.patch
+ epatch "${FILESDIR}"/gdb-6.5-locale.patch
strip-linguas -u bfd/po opcodes/po
}