summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-26 23:07:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-26 23:07:44 +0000
commit6f6e72c953ded3b76a9a01420df32e516dbed227 (patch)
tree00c98d0abc143eb36a25f5e7475a8f0f5c99399b /sys-devel/libtool
parentclean up doc files #90372 (diff)
downloadgentoo-2-6f6e72c953ded3b76a9a01420df32e516dbed227.tar.gz
gentoo-2-6f6e72c953ded3b76a9a01420df32e516dbed227.tar.bz2
gentoo-2-6f6e72c953ded3b76a9a01420df32e516dbed227.zip
alpha stable
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/libtool-1.3.5.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/sys-devel/libtool/libtool-1.3.5.ebuild b/sys-devel/libtool/libtool-1.3.5.ebuild
index 7dc92347864f..c8bedf5d8522 100644
--- a/sys-devel/libtool/libtool-1.3.5.ebuild
+++ b/sys-devel/libtool/libtool-1.3.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.3.5.ebuild,v 1.5 2005/03/09 02:13:41 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.3.5.ebuild,v 1.6 2005/04/26 23:07:44 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
-inherit eutils gnuconfig libtool
+inherit eutils libtool
DESCRIPTION="A shared library tool for developers"
HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
@@ -10,11 +10,10 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="1.3"
-KEYWORDS="~alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE=""
-DEPEND="virtual/libc
- >=sys-devel/autoconf-2.58
+DEPEND=">=sys-devel/autoconf-2.58
>=sys-devel/automake-1.8.3"
# the autoconf dep is due to it complaining 'configure.ac:55: error: Autoconf version 2.58 or higher is required'
# the automake dep is due to Bug #46037
@@ -29,7 +28,7 @@ src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
echo
# Install updated missing script
portageq has_version / "sys-devel/automake" && {
@@ -37,12 +36,11 @@ src_unpack() {
automake --add-missing
}
- epatch ${FILESDIR}/1.4.3/${PN}-1.2f-cache.patch
- epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-nonneg.patch
- epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
+ epatch "${FILESDIR}"/1.4.3/${PN}-1.2f-cache.patch
+ epatch "${FILESDIR}"/1.4.3/${PN}-1.3.5-nonneg.patch
+ epatch "${FILESDIR}"/1.4.3/${PN}-1.3.5-mktemp.patch
uclibctoolize
- gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -53,9 +51,9 @@ src_compile() {
src_install() {
cd libltdl
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
- # basically we just install for old packages
+ # basically we just install ABI libs for old packages
rm -r "${D}"/usr/include
rm -f "${D}"/usr/lib/libltdl.{a,la,so}
}