summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-24 08:07:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-24 08:07:35 +0000
commitf504e494f61f719ebf0b6262729cb3c4a73aff45 (patch)
tree83d50d4bc5ee65b83d318f20fbb21b68a81eaec5 /sys-devel/patch/patch-2.5.9.ebuild
parentarm KEYWORD (diff)
downloadgentoo-2-f504e494f61f719ebf0b6262729cb3c4a73aff45.tar.gz
gentoo-2-f504e494f61f719ebf0b6262729cb3c4a73aff45.tar.bz2
gentoo-2-f504e494f61f719ebf0b6262729cb3c4a73aff45.zip
arm KEYWORD
Diffstat (limited to 'sys-devel/patch/patch-2.5.9.ebuild')
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index 6713e190cc22..b56b7b5f6b2c 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.14 2004/03/29 21:53:56 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.15 2004/04/24 08:06:20 vapier Exp $
inherit flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86 ppc sparc alpha mips hppa ia64 ppc64 s390"
+KEYWORDS="x86 ppc ppc64 sparc mips alpha arm hppa amd64 ia64 s390"
IUSE="build static"
DEPEND="virtual/glibc"
@@ -22,7 +22,7 @@ src_compile() {
CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
ac_cv_sys_long_file_names=yes \
./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
- if [ -z "`use static`" ]; then
+ if ! use static ; then
emake || die "emake failed"
else
emake LDFLAGS=-static || die "emake failed"
@@ -31,8 +31,8 @@ src_compile() {
src_install() {
einstall
- if [ -z "`use build`" ]; then
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ if ! use build ; then
+ dodoc AUTHORS ChangeLog NEWS README
else
rm -rf ${D}/usr/share/man
fi