summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 18:16:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 18:16:03 +0000
commitcc99d73451633bcb7b97273e4dc5d457030dd042 (patch)
treef3db8113c3ec995ac05284bfa7fca25bd05cd859 /sys-devel/patch
parentNow uses USE nls static build (diff)
downloadgentoo-2-cc99d73451633bcb7b97273e4dc5d457030dd042.tar.gz
gentoo-2-cc99d73451633bcb7b97273e4dc5d457030dd042.tar.bz2
gentoo-2-cc99d73451633bcb7b97273e4dc5d457030dd042.zip
Now uses static and build USE flags
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/files/digest-patch-2.5.4-r31
-rw-r--r--sys-devel/patch/patch-2.5.4-r3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-devel/patch/files/digest-patch-2.5.4-r3 b/sys-devel/patch/files/digest-patch-2.5.4-r3
new file mode 100644
index 000000000000..528dd04a27b6
--- /dev/null
+++ b/sys-devel/patch/files/digest-patch-2.5.4-r3
@@ -0,0 +1 @@
+MD5 ee5ae84d115f051d87fcaaef3b4ae782 patch-2.5.4.tar.gz
diff --git a/sys-devel/patch/patch-2.5.4-r3.ebuild b/sys-devel/patch/patch-2.5.4-r3.ebuild
new file mode 100644
index 000000000000..1ff2e3fc4600
--- /dev/null
+++ b/sys-devel/patch/patch-2.5.4-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.4-r3.ebuild,v 1.1 2001/02/27 18:16:03 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Utility to apply diffs to files"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/patch/${A}
+ ftp://ftp.gnu.org/gnu/patch/${A}"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+
+}
+
+
+