summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-07 21:58:29 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-07 21:58:29 +0000
commit04efef8269c49ecdd9a417a67650babe6af59131 (patch)
treea0abfd72d4b7e2347eae9f2544a2a6338c71b992 /sys-devel
parentversion bump (diff)
downloadgentoo-2-04efef8269c49ecdd9a417a67650babe6af59131.tar.gz
gentoo-2-04efef8269c49ecdd9a417a67650babe6af59131.tar.bz2
gentoo-2-04efef8269c49ecdd9a417a67650babe6af59131.zip
Add support for USE=git.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gettext/ChangeLog8
-rw-r--r--sys-devel/gettext/gettext-0.18.1.1-r1.ebuild100
-rw-r--r--sys-devel/gettext/metadata.xml4
3 files changed, 111 insertions, 1 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 1b166c71e74a..355144f0a0e5 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.181 2010/07/01 15:57:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.182 2010/08/07 21:58:29 vapier Exp $
+
+*gettext-0.18.1.1-r1 (07 Aug 2010)
+
+ 07 Aug 2010; Mike Frysinger <vapier@gentoo.org> +gettext-0.18.1.1-r1.ebuild,
+ metadata.xml:
+ Add support for USE=git.
01 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
gettext-0.18.1.ebuild, gettext-0.18.1.1.ebuild:
diff --git a/sys-devel/gettext/gettext-0.18.1.1-r1.ebuild b/sys-devel/gettext/gettext-0.18.1.1-r1.ebuild
new file mode 100644
index 000000000000..af59cb34ee56
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.18.1.1-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.18.1.1-r1.ebuild,v 1.1 2010/08/07 21:58:29 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils multilib toolchain-funcs mono libtool
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="acl doc emacs +git nls nocxx openmp elibc_glibc"
+
+DEPEND="virtual/libiconv
+ dev-libs/libxml2
+ sys-libs/ncurses
+ dev-libs/expat
+ acl? ( virtual/acl )"
+RDEPEND="${DEPEND}
+ git? ( dev-vcs/git )"
+PDEPEND="emacs? ( app-emacs/po-mode )"
+
+src_prepare() {
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf=""
+ # Build with --without-included-gettext (on glibc systems)
+ if use elibc_glibc ; then
+ myconf="${myconf} --without-included-gettext $(use_enable nls)"
+ else
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ fi
+ use nocxx && export CXX=$(tc-getCC)
+
+ # --without-emacs: Emacs support is now in a separate package
+ # --with-included-glib: glib depends on us so avoid circular deps
+ # --with-included-libcroco: libcroco depends on glib which ... ^^^
+ #
+ # --with-included-libunistring will _disable_ libunistring (since
+ # --it's not bundled), see bug #326477
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --without-emacs \
+ --disable-java \
+ --with-included-glib \
+ --with-included-libcroco \
+ --with-included-libunistring \
+ $(use_enable acl) \
+ $(use_enable openmp) \
+ $(use_with git) \
+ --without-cvs
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use nls || rm -r "${D}"/usr/share/locale
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+ dobin gettext-tools/misc/gettextize || die "gettextize"
+
+ # remove stuff that glibc handles
+ if use elibc_glibc ; then
+ rm -f "${D}"/usr/include/libintl.h
+ rm -f "${D}"/usr/$(get_libdir)/libintl.*
+ fi
+ rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
+
+ if [[ ${USERLAND} == "BSD" ]] ; then
+ libname="libintl$(get_libname)"
+ # Move dynamic libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
+ gen_usr_ldscript ${libname}
+ fi
+
+ if use doc ; then
+ dohtml "${D}"/usr/share/doc/${PF}/*.html
+ else
+ rm -rf "${D}"/usr/share/doc/${PF}/{csharpdoc,examples,javadoc2,javadoc1}
+ fi
+ rm -f "${D}"/usr/share/doc/${PF}/*.html
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_preinst() {
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ preserve_old_lib /{,usr/}$(get_libdir)/libintl$(get_libname 7)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /{,usr/}$(get_libdir)/libintl$(get_libname 7)
+}
diff --git a/sys-devel/gettext/metadata.xml b/sys-devel/gettext/metadata.xml
index 96a2d586367d..37c817a947a6 100644
--- a/sys-devel/gettext/metadata.xml
+++ b/sys-devel/gettext/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
+<use>
+ <flag name="git">When running `autopoint`, use git to store the internal development files;
+ this requires git at runtime, but will be faster/smaller than raw archives</flag>
+</use>
</pkgmetadata>