summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-11 18:18:46 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-11 18:18:46 +0000
commit09f3261a96bb1cf72092602e7ce92918f4390a3e (patch)
tree11590c305f5f5f247d6edaf255df90431ac01cc3 /sys-devel
parentfix typos (Manifest recommit) (diff)
downloadgentoo-2-09f3261a96bb1cf72092602e7ce92918f4390a3e.tar.gz
gentoo-2-09f3261a96bb1cf72092602e7ce92918f4390a3e.tar.bz2
gentoo-2-09f3261a96bb1cf72092602e7ce92918f4390a3e.zip
added a fix for bug 55108, where enabling multilib caused gcc to fail compiling with "Link tests are not allowed after GCC_NO_EXECUTABLES"
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/3.4.1/gcc-3.4.1-glibc-is-native.patch19
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r2.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.4.1.ebuild11
4 files changed, 46 insertions, 3 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index be900f811353..a4d718013cfb 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.300 2004/08/08 00:45:48 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.301 2004/08/11 18:18:46 lv Exp $
+
+ 11 Aug 2004; Travis Tilley <lv@gentoo.org>
+ +files/3.4.1/gcc-3.4.1-glibc-is-native.patch, gcc-3.4.1-r2.ebuild,
+ gcc-3.4.1.ebuild:
+ added a fix for bug 55108, where enabling multilib caused gcc to fail
+ compiling with "Link tests are not allowed after GCC_NO_EXECUTABLES"
08 Aug 2004; Tom Martin <slarti@gentoo.org> gcc-3.3.3-r3.ebuild,
gcc-3.3.3-r4.ebuild, gcc-3.3.3-r5.ebuild, gcc-3.3.3-r6.ebuild,
diff --git a/sys-devel/gcc/files/3.4.1/gcc-3.4.1-glibc-is-native.patch b/sys-devel/gcc/files/3.4.1/gcc-3.4.1-glibc-is-native.patch
new file mode 100644
index 000000000000..8bd8ca9d279a
--- /dev/null
+++ b/sys-devel/gcc/files/3.4.1/gcc-3.4.1-glibc-is-native.patch
@@ -0,0 +1,19 @@
+--- gcc-3.4.1.old/libstdc++-v3/configure.ac 2004-08-11 09:17:51.817618280 -0400
++++ gcc-3.4.1/libstdc++-v3/configure.ac 2004-08-11 09:30:10.708289824 -0400
+@@ -39,13 +39,9 @@
+ # Handy for debugging:
+ #AC_MSG_NOTICE($build / $host / $target / $host_alias / $target_alias); sleep 5
+
+-if test "$build" != "$host"; then
+- # We are being configured with some form of cross compiler.
+- GLIBCXX_IS_NATIVE=false
+- GCC_NO_EXECUTABLES
+-else
+- GLIBCXX_IS_NATIVE=true
+-fi
++# it seems this gcc always gets this check wrong for multilib on gentoo, so
++# lets force it to the value it should be.
++GLIBCXX_IS_NATIVE=true
+
+ # Sets up automake. Must come after AC_CANONICAL_SYSTEM. Each of the
+ # following is magically included in AUTOMAKE_OPTIONS in each Makefile.am.
diff --git a/sys-devel/gcc/gcc-3.4.1-r2.ebuild b/sys-devel/gcc/gcc-3.4.1-r2.ebuild
index bd045fb55219..3fb1b1849651 100644
--- a/sys-devel/gcc/gcc-3.4.1-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r2.ebuild,v 1.3 2004/08/08 00:45:48 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r2.ebuild,v 1.4 2004/08/11 18:18:46 lv Exp $
IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
@@ -498,6 +498,15 @@ src_unpack() {
# misc patches that havent made it into a patch tarball yet
epatch ${FILESDIR}/3.4.0/gcc34-reiser4-fix.patch
+ if use amd64 && use multilib ; then
+ # this should hack around the GCC_NO_EXECUTABLES bug
+ epatch ${FILESDIR}/3.4.1/gcc-3.4.1-glibc-is-native.patch
+ cd ${S}/libstdc++-v3
+ einfo "running autoreconf..."
+ autoreconf
+ cd ${S}
+ fi
+
# Misdesign in libstdc++ (Redhat)
cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
diff --git a/sys-devel/gcc/gcc-3.4.1.ebuild b/sys-devel/gcc/gcc-3.4.1.ebuild
index 65ea0cbbc70a..4b989919ad18 100644
--- a/sys-devel/gcc/gcc-3.4.1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.18 2004/08/09 03:09:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.19 2004/08/11 18:18:46 lv Exp $
inherit eutils flag-o-matic libtool gnuconfig
@@ -488,6 +488,15 @@ src_unpack() {
epatch ${FILESDIR}/3.4.0/gcc34-reiser4-fix.patch
epatch ${FILESDIR}/3.4.1/gcc341-ppc64-mozilla-ICE-fix.patch
+ if use amd64 && use multilib ; then
+ # this should hack around the GCC_NO_EXECUTABLES bug
+ epatch ${FILESDIR}/3.4.1/gcc-3.4.1-glibc-is-native.patch
+ cd ${S}/libstdc++-v3
+ einfo "running autoreconf..."
+ autoreconf
+ cd ${S}
+ fi
+
# Misdesign in libstdc++ (Redhat)
cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h