summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2003-02-05 10:33:54 +0000
committerJ Robert Ray <jrray@gentoo.org>2003-02-05 10:33:54 +0000
commit177ff24a7550cd71ce5291220fce250d3ffba138 (patch)
tree55fcb4bcd24e60a56de159a8f77a647927eb1b32 /sys-devel
parentAdded a small patch to fix a security problem, fixes bug #15154. (diff)
downloadgentoo-2-177ff24a7550cd71ce5291220fce250d3ffba138.tar.gz
gentoo-2-177ff24a7550cd71ce5291220fce250d3ffba138.tar.bz2
gentoo-2-177ff24a7550cd71ce5291220fce250d3ffba138.zip
Filter "-malign-double" from CFLAGS.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/perl/ChangeLog5
-rw-r--r--sys-devel/perl/perl-5.8.0-r9.ebuild4
2 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/perl/ChangeLog b/sys-devel/perl/ChangeLog
index 1eb3431f0c9d..97c54502544a 100644
--- a/sys-devel/perl/ChangeLog
+++ b/sys-devel/perl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/perl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.50 2003/01/19 16:54:11 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.51 2003/02/05 10:33:54 jrray Exp $
+
+ 05 Feb 2003; J Robert Ray <jrray@gentoo.org> perl-5.8.0-r9.ebuild; Changed to strip
+ "-malign-double" from CFLAGS, fixing bug 14608.
17 Jan 2003;Michael Cummings <mcummings@gentoo.org> perl-5.8.0-r9;
diff --git a/sys-devel/perl/perl-5.8.0-r9.ebuild b/sys-devel/perl/perl-5.8.0-r9.ebuild
index 5882a360874c..8fb00d20bf1f 100644
--- a/sys-devel/perl/perl-5.8.0-r9.ebuild
+++ b/sys-devel/perl/perl-5.8.0-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r9.ebuild,v 1.5 2003/01/19 16:13:04 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r9.ebuild,v 1.6 2003/02/05 10:33:54 jrray Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -59,6 +59,8 @@ inherit eutils flag-o-matic
# Perl has problems compiling with -Os in your flags
replace-flags "-Os" "-O2"
+# This flag makes compiling crash in interesting ways
+filter-flags "-malign-double"
# The slot of this binary compat version of libperl.so