summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-08-12 18:58:06 +0000
committerFabian Groffen <grobian@gentoo.org>2012-08-12 18:58:06 +0000
commit22117f5e96c00ea22ecc412facb42756cdfe72e7 (patch)
tree69171ea0b155f3aa46564671b2d4a241866619fe /sys-devel
parentInitial commit, ebuild by me. Thanks to zerochaos for testing. (diff)
downloadgentoo-2-22117f5e96c00ea22ecc412facb42756cdfe72e7.tar.gz
gentoo-2-22117f5e96c00ea22ecc412facb42756cdfe72e7.tar.bz2
gentoo-2-22117f5e96c00ea22ecc412facb42756cdfe72e7.zip
Serialise cctools building, the makefiles are completely not capable of doing parallelism, it seems
(Portage version: 2.2.01.20837-prefix/cvs/Darwin i386)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-apple/ChangeLog7
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.3.ebuild4
2 files changed, 9 insertions, 2 deletions
diff --git a/sys-devel/binutils-apple/ChangeLog b/sys-devel/binutils-apple/ChangeLog
index 283c6b1f4b9f..a82d4aa9bb83 100644
--- a/sys-devel/binutils-apple/ChangeLog
+++ b/sys-devel/binutils-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/binutils-apple
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.33 2012/08/10 09:19:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.34 2012/08/12 18:58:06 grobian Exp $
+
+ 12 Aug 2012; Fabian Groffen <grobian@gentoo.org> binutils-apple-3.2.ebuild,
+ binutils-apple-4.3.ebuild:
+ Serialise cctools building, the makefiles are completely not capable of doing
+ parallelism, it seems
*binutils-apple-3.2 (10 Aug 2012)
diff --git a/sys-devel/binutils-apple/binutils-apple-4.3.ebuild b/sys-devel/binutils-apple/binutils-apple-4.3.ebuild
index 772b2ec52f9a..bed18e0c50c5 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.3.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.3.ebuild,v 1.2 2012/03/05 11:47:13 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.3.ebuild,v 1.3 2012/08/12 18:58:06 grobian Exp $
EAPI="3"
@@ -208,12 +208,14 @@ compile_ld64() {
compile_cctools() {
einfo "building ${CCTOOLS}"
cd "${S}"/${CCTOOLS}
+ # -j1 because it fails too often with weird errors
emake \
LIB_PRUNETRIE="-L../../${LD64}/src -lprunetrie" \
EFITOOLS= LTO= \
COMMON_SUBDIRS='libstuff ar misc otool' \
SUBDIRS_32= \
RC_CFLAGS="${CFLAGS}" OFLAG="${CFLAGS}" \
+ -j1 \
|| die "emake failed for the cctools"
cd "${S}"/${CCTOOLS}/as
emake \