summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-07-14 14:53:52 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-07-14 14:53:52 +0000
commit3fc989cf7b9c428abefcc79a1f5c434ac51d65f2 (patch)
treea2a35a79acb2ad026385f7eaa4d9584fcc471911 /sys-devel
parentPunt bogus USE="qt4" (mistakenly forwarded from ebuild of 1.0) wrt #515338 by... (diff)
downloadgentoo-2-3fc989cf7b9c428abefcc79a1f5c434ac51d65f2.tar.gz
gentoo-2-3fc989cf7b9c428abefcc79a1f5c434ac51d65f2.tar.bz2
gentoo-2-3fc989cf7b9c428abefcc79a1f5c434ac51d65f2.zip
Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug 513718
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/llvm-3.3-r3.ebuild6
-rw-r--r--sys-devel/llvm/llvm-3.4.1-r2.ebuild8
-rw-r--r--sys-devel/llvm/llvm-3.4.2.ebuild8
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild8
5 files changed, 21 insertions, 16 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index a33e06dc1dda..83c681ea4485 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.202 2014/06/29 09:59:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.203 2014/07/14 14:53:52 axs Exp $
+
+ 14 Jul 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> llvm-3.3-r3.ebuild,
+ llvm-3.4.1-r2.ebuild, llvm-3.4.2.ebuild, llvm-9999.ebuild:
+ Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug
+ 513718
29 Jun 2014; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
Rename clang to ${CHOST}-clang-${PV}. Add multilib wrappers.
diff --git a/sys-devel/llvm/llvm-3.3-r3.ebuild b/sys-devel/llvm/llvm-3.3-r3.ebuild
index 94a8b523a433..5bb53e37d2f3 100644
--- a/sys-devel/llvm/llvm-3.3-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r3.ebuild,v 1.11 2014/06/15 14:30:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r3.ebuild,v 1.12 2014/07/14 14:53:52 axs Exp $
EAPI=5
@@ -34,9 +34,9 @@ COMMON_DEPEND="
xml? ( dev-libs/libxml2:2= )
)
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
- libffi? ( virtual/libffi:0=[${MULTILIB_USEDEP}] )
+ libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ocaml? ( dev-lang/ocaml:0= )
- udis86? ( dev-libs/udis86:0=[pic(+),${MULTILIB_USEDEP}] )"
+ udis86? ( >=dev-libs/udis86-1.7-r2:0=[pic(+),${MULTILIB_USEDEP}] )"
DEPEND="${COMMON_DEPEND}
dev-lang/perl
>=sys-devel/make-3.81
diff --git a/sys-devel/llvm/llvm-3.4.1-r2.ebuild b/sys-devel/llvm/llvm-3.4.1-r2.ebuild
index 5e84a3ae44f7..837f52d34dfa 100644
--- a/sys-devel/llvm/llvm-3.4.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r2.ebuild,v 1.1 2014/06/14 18:49:46 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r2.ebuild,v 1.2 2014/07/14 14:53:52 axs Exp $
EAPI=5
@@ -38,10 +38,10 @@ COMMON_DEPEND="
xml? ( dev-libs/libxml2:2= )
)
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
- libffi? ( virtual/libffi:0=[${MULTILIB_USEDEP}] )
- ncurses? ( sys-libs/ncurses:5=[${MULTILIB_USEDEP}] )
+ libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
+ ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
ocaml? ( dev-lang/ocaml:0= )
- udis86? ( dev-libs/udis86:0=[pic(+),${MULTILIB_USEDEP}] )"
+ udis86? ( >=dev-libs/udis86-1.7-r2:0=[pic(+),${MULTILIB_USEDEP}] )"
DEPEND="${COMMON_DEPEND}
dev-lang/perl
>=sys-devel/make-3.81
diff --git a/sys-devel/llvm/llvm-3.4.2.ebuild b/sys-devel/llvm/llvm-3.4.2.ebuild
index 54a5642093ec..d1f239db4cbe 100644
--- a/sys-devel/llvm/llvm-3.4.2.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.1 2014/06/23 23:00:42 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.2 2014/07/14 14:53:52 axs Exp $
EAPI=5
@@ -38,10 +38,10 @@ COMMON_DEPEND="
xml? ( dev-libs/libxml2:2= )
)
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
- libffi? ( virtual/libffi:0=[${MULTILIB_USEDEP}] )
- ncurses? ( sys-libs/ncurses:5=[${MULTILIB_USEDEP}] )
+ libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
+ ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
ocaml? ( dev-lang/ocaml:0= )
- udis86? ( dev-libs/udis86:0=[pic(+),${MULTILIB_USEDEP}] )"
+ udis86? ( >=dev-libs/udis86-1.7-r2:0=[pic(+),${MULTILIB_USEDEP}] )"
DEPEND="${COMMON_DEPEND}
dev-lang/perl
>=sys-devel/make-3.81
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 33ff7779a69d..0fb2aba93421 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.88 2014/06/29 09:59:32 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.89 2014/07/14 14:53:52 axs Exp $
EAPI=5
@@ -32,10 +32,10 @@ COMMON_DEPEND="
xml? ( dev-libs/libxml2:2= )
)
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
- libffi? ( virtual/libffi:0=[${MULTILIB_USEDEP}] )
- ncurses? ( sys-libs/ncurses:5=[${MULTILIB_USEDEP}] )
+ libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
+ ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
ocaml? ( dev-lang/ocaml:0= )
- udis86? ( dev-libs/udis86:0=[pic(+),${MULTILIB_USEDEP}] )"
+ udis86? ( >=dev-libs/udis86-1.7-r2:0=[pic(+),${MULTILIB_USEDEP}] )"
DEPEND="${COMMON_DEPEND}
dev-lang/perl
dev-python/sphinx