summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-19 19:08:25 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-19 19:08:25 +0000
commit4d382d4bfc73c0e66cb7b1585f47d97201a5e0f9 (patch)
tree7bb3df3495b4253c5d0ff49ceee76c9899efb529 /sys-devel
parentamd64/x86 stable wrt bug #492204 (diff)
downloadgentoo-2-4d382d4bfc73c0e66cb7b1585f47d97201a5e0f9.tar.gz
gentoo-2-4d382d4bfc73c0e66cb7b1585f47d97201a5e0f9.tar.bz2
gentoo-2-4d382d4bfc73c0e66cb7b1585f47d97201a5e0f9.zip
Symlink the LLVM gold plugin to bfd-plugins directory to enable LLVM object support in various binutils tools, bug #462554.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild8
2 files changed, 12 insertions, 2 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 0e050f3abafb..091ef0053285 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.151 2013/12/19 17:26:35 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.152 2013/12/19 19:08:25 mgorny Exp $
+
+ 19 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Symlink the LLVM gold plugin to bfd-plugins directory to enable LLVM object
+ support in various binutils tools, bug #462554.
19 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
Remove traces of BugpointPasses in darwin branch.
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index d8afcf90a3a4..9e177f06b738 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.65 2013/12/19 17:26:35 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.66 2013/12/19 19:08:25 mgorny Exp $
EAPI=5
@@ -329,9 +329,15 @@ multilib_src_install() {
mv "${ED}"/tmp/llvm-config.* "${ED}"/usr/bin || die
fi
+ # Install docs.
doman "${S}"/docs/_build/man/*.1
use clang && doman "${T}"/clang.1
use doc && dohtml -r "${S}"/docs/_build/html/
+
+ # Symlink the gold plugin.
+ dodir /usr/${CHOST}/binutils-bin/lib/bfd-plugins
+ dosym ../../../../$(get_libdir)/LLVMgold.so \
+ /usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so
else
# Preserve ABI-variant of llvm-config,
# then drop all the executables since LLVM doesn't like to