summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-02-10 22:07:53 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-02-10 22:07:53 +0000
commit6854aa8d0936b330dd1f63afced0cee7b89689bc (patch)
tree904452693134d81b310d8482b37b3a82d2894e30 /sys-devel
parentSecurity bump for #539482. Proxy commit for ssuominen. (diff)
downloadgentoo-2-6854aa8d0936b330dd1f63afced0cee7b89689bc.tar.gz
gentoo-2-6854aa8d0936b330dd1f63afced0cee7b89689bc.tar.bz2
gentoo-2-6854aa8d0936b330dd1f63afced0cee7b89689bc.zip
Added hdf5 support
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/byfl/ChangeLog6
-rw-r--r--sys-devel/byfl/byfl-1.1.ebuild9
-rw-r--r--sys-devel/byfl/byfl-9999.ebuild9
3 files changed, 15 insertions, 9 deletions
diff --git a/sys-devel/byfl/ChangeLog b/sys-devel/byfl/ChangeLog
index ffa2104708e8..73093220823a 100644
--- a/sys-devel/byfl/ChangeLog
+++ b/sys-devel/byfl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/byfl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/ChangeLog,v 1.10 2015/02/10 21:18:46 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/ChangeLog,v 1.11 2015/02/10 22:07:53 ottxor Exp $
+
+ 10 Feb 2015; Christoph Junghans <ottxor@gentoo.org> byfl-1.1.ebuild,
+ byfl-9999.ebuild:
+ Added hdf5 support
10 Feb 2015; Christoph Junghans <ottxor@gentoo.org> -byfl-1.0.ebuild,
byfl-1.1.ebuild:
diff --git a/sys-devel/byfl/byfl-1.1.ebuild b/sys-devel/byfl/byfl-1.1.ebuild
index d756b21020a2..a4d42d25a614 100644
--- a/sys-devel/byfl/byfl-1.1.ebuild
+++ b/sys-devel/byfl/byfl-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-1.1.ebuild,v 1.2 2015/02/10 21:04:46 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-1.1.ebuild,v 1.3 2015/02/10 22:07:53 ottxor Exp $
EAPI=5
@@ -24,16 +24,17 @@ HOMEPAGE="https://github.com/losalamos/Byfl"
SLOT="0"
LICENSE="BSD"
-IUSE=""
+IUSE="hdf5"
RDEPEND="~sys-devel/dragonegg-${LLVM_VERSION}
~sys-devel/clang-${LLVM_VERSION}
~sys-devel/llvm-${LLVM_VERSION}
dev-lang/perl:=
- dev-perl/Switch"
+ dev-perl/Switch
+ hdf5? ( sci-libs/hdf5 )"
DEPEND="${RDEPEND}"
src_configure() {
append-cxxflags -std=c++11
- autotools-utils_src_configure
+ autotools-utils_src_configure H5CXX=$(usex hdf5 h5c++ no)
}
diff --git a/sys-devel/byfl/byfl-9999.ebuild b/sys-devel/byfl/byfl-9999.ebuild
index 7724d53d768c..cf193f7a0a77 100644
--- a/sys-devel/byfl/byfl-9999.ebuild
+++ b/sys-devel/byfl/byfl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-9999.ebuild,v 1.8 2015/02/10 21:04:46 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-9999.ebuild,v 1.9 2015/02/10 22:07:53 ottxor Exp $
EAPI=5
@@ -24,16 +24,17 @@ HOMEPAGE="https://github.com/losalamos/Byfl"
SLOT="0"
LICENSE="BSD"
-IUSE=""
+IUSE="hdf5"
RDEPEND="~sys-devel/dragonegg-${LLVM_VERSION}
~sys-devel/clang-${LLVM_VERSION}
~sys-devel/llvm-${LLVM_VERSION}
dev-lang/perl:=
- dev-perl/Switch"
+ dev-perl/Switch
+ hdf5? ( sci-libs/hdf5 )"
DEPEND="${RDEPEND}"
src_configure() {
append-cxxflags -std=c++11
- autotools-utils_src_configure
+ autotools-utils_src_configure H5CXX=$(usex hdf5 h5c++ no)
}