summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-10-19 20:17:33 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-10-19 20:17:33 +0000
commit71d62b5c11a17fc69d07721d8cca8cfe3c7893f9 (patch)
tree4c23b91290634178ffde58066d203e69fb8c36c0 /sys-devel
parent*** empty log message *** (diff)
downloadgentoo-2-71d62b5c11a17fc69d07721d8cca8cfe3c7893f9.tar.gz
gentoo-2-71d62b5c11a17fc69d07721d8cca8cfe3c7893f9.tar.bz2
gentoo-2-71d62b5c11a17fc69d07721d8cca8cfe3c7893f9.zip
added fchksum
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/python-basic/files/digest-python-basic-1.5.2-r22
-rw-r--r--sys-devel/python-basic/python-basic-1.5.2-r2.ebuild (renamed from sys-devel/python-basic/python-basic-1.5.2-r1.ebuild)13
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-devel/python-basic/files/digest-python-basic-1.5.2-r2 b/sys-devel/python-basic/files/digest-python-basic-1.5.2-r2
new file mode 100644
index 000000000000..aeb14243568a
--- /dev/null
+++ b/sys-devel/python-basic/files/digest-python-basic-1.5.2-r2
@@ -0,0 +1,2 @@
+MD5 e9d677ae6d5a3efc6937627ed8a3e752 py152.tgz
+MD5 7c99113a11b03599d8494638f6d90b56 python-fchksum-1.1.tar.gz
diff --git a/sys-devel/python-basic/python-basic-1.5.2-r1.ebuild b/sys-devel/python-basic/python-basic-1.5.2-r2.ebuild
index f7688acee04b..a51803a71511 100644
--- a/sys-devel/python-basic/python-basic-1.5.2-r1.ebuild
+++ b/sys-devel/python-basic/python-basic-1.5.2-r2.ebuild
@@ -1,19 +1,23 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/python-basic/python-basic-1.5.2-r1.ebuild,v 1.3 2000/09/15 20:09:26 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/python-basic/python-basic-1.5.2-r2.ebuild,v 1.1 2000/10/19 20:17:33 drobbins Exp $
P=python-basic-1.5.2
-A=py152.tgz
+A="py152.tgz python-fchksum-1.1.tar.gz"
S=${WORKDIR}/Python-1.5.2
+S2=${WORKDIR}/python-fchksum-1.1
DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/src/${A}"
+SRC_URI="http://www.python.org/ftp/python/src/${A} http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
src_compile() {
try ./configure --prefix=/usr --with-threads
cp Makefile Makefile.orig
sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
try make
+ cd ${S2}
+ ./configure
+ try make
}
src_unpack() {
@@ -32,6 +36,9 @@ Setup.in > Setup
src_install() {
dodir /usr
try make install prefix=${D}/usr
+ cd ${S2}
+ try make prefix=${D}/usr install
+ cd ${S}
prepman
strip ${D}/usr/bin/python