summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-06-06 19:40:25 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-06-06 19:40:25 +0000
commit784b9ad8bb502bbf81d4b07324f065a57eca99d6 (patch)
tree4e0c1b412e9d8fc1838d02e66d670025ea7d6d5c /sys-devel
parentVersion bump (diff)
downloadgentoo-2-784b9ad8bb502bbf81d4b07324f065a57eca99d6.tar.gz
gentoo-2-784b9ad8bb502bbf81d4b07324f065a57eca99d6.tar.bz2
gentoo-2-784b9ad8bb502bbf81d4b07324f065a57eca99d6.zip
Update live ebuild to sync latest ebuild changes, fixes bug #369027
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog5
-rw-r--r--sys-devel/clang/clang-9999.ebuild22
2 files changed, 19 insertions, 8 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 16ff1646b9cd..512669029de4 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.37 2011/04/22 11:10:50 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.38 2011/06/06 19:40:25 voyageur Exp $
+
+ 06 Jun 2011; Bernard Cafarelli <voyageur@gentoo.org> clang-9999.ebuild:
+ Update live ebuild to sync latest ebuild changes, fixes bug #369027
21 Apr 2011; Fabian Groffen <grobian@gentoo.org> clang-2.9.ebuild:
Update install_name reference to libLLVM
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index a3db73f175d0..1d0362d73149 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.12 2011/01/26 17:48:41 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.13 2011/06/06 19:40:25 voyageur Exp $
EAPI=3
@@ -17,11 +17,11 @@ ESVN_REPO_URI="http://llvm.org/svn/llvm-project/cfe/trunk"
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE="debug +static-analyzer system-cxx-headers test"
+IUSE="alltargets debug +static-analyzer system-cxx-headers test"
# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
DEPEND="static-analyzer? ( dev-lang/perl )"
-RDEPEND="~sys-devel/llvm-${PV}"
+RDEPEND="~sys-devel/llvm-${PV}[alltargets=]"
S="${WORKDIR}/llvm"
@@ -62,7 +62,7 @@ src_prepare() {
}
src_configure() {
- local CONF_FLAGS=""
+ local CONF_FLAGS="--enable-shared"
if use debug; then
CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
@@ -81,6 +81,12 @@ src_configure() {
--with-c-include-dirs=${EPREFIX}/usr/include:/usr/include"
fi
+ if use alltargets; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
+ else
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
+ fi
+
if use amd64; then
CONF_FLAGS="${CONF_FLAGS} --enable-pic"
fi
@@ -89,8 +95,10 @@ src_configure() {
CONF_FLAGS="${CONF_FLAGS} --with-llvmgccdir=/dev/null"
if use system-cxx-headers; then
- # Try to get current C++ headers path
- CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=$(gcc-config -X| cut -d: -f1 | sed '/-v4$/! s,$,/include/g++-v4,')"
+ # Try to get current gcc headers path
+ local CXX_PATH=$(gcc-config -X| cut -d: -f1 | sed 's,/include/g++-v4$,,')
+ CONF_FLAGS="${CONF_FLAGS} --with-c-include-dirs=/usr/include:${CXX_PATH}/include"
+ CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=${CXX_PATH}/include/g++-v4"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"
if has_multilib_profile; then
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-32bit-dir=32"
@@ -154,7 +162,7 @@ src_install() {
install_name_tool \
-change "@rpath/libclang.dylib" \
"${EPREFIX}"/usr/lib/llvm/libclang.dylib \
- -change "${S}"/Release/lib/libLLVM-${PV}.dylib \
+ -change "@executable_path/../lib/libLLVM-${PV}.dylib" \
"${EPREFIX}"/usr/lib/llvm/libLLVM-${PV}.dylib \
-change "${S}"/Release/lib/libclang.dylib \
"${EPREFIX}"/usr/lib/llvm/libclang.dylib \