summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-03-04 16:40:18 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-03-04 16:40:18 +0000
commit7fadf9dd7ed2ea7f11993010411cf1fa743dd0ed (patch)
tree5702a84f80b6b93f5dd27b3fdb26e0cb9c96c295 /sys-devel
parentSplit magic powder function into EAPI 5 appropriate src_configure, src_compil... (diff)
downloadgentoo-2-7fadf9dd7ed2ea7f11993010411cf1fa743dd0ed.tar.gz
gentoo-2-7fadf9dd7ed2ea7f11993010411cf1fa743dd0ed.tar.bz2
gentoo-2-7fadf9dd7ed2ea7f11993010411cf1fa743dd0ed.zip
Initial commit, ebuild written by me.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/dwz/ChangeLog9
-rw-r--r--sys-devel/dwz/dwz-0.9.ebuild23
-rw-r--r--sys-devel/dwz/metadata.xml17
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/dwz/ChangeLog b/sys-devel/dwz/ChangeLog
new file mode 100644
index 000000000000..f4b86c764345
--- /dev/null
+++ b/sys-devel/dwz/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-devel/dwz
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dwz/ChangeLog,v 1.1 2013/03/04 16:40:18 dev-zero Exp $
+
+*dwz-0.9 (04 Mar 2013)
+
+ 04 Mar 2013; Tiziano Müller <dev-zero@gentoo.org> +dwz-0.9.ebuild,
+ +metadata.xml:
+ Initial commit, ebuild written by me.
diff --git a/sys-devel/dwz/dwz-0.9.ebuild b/sys-devel/dwz/dwz-0.9.ebuild
new file mode 100644
index 000000000000..9ccbbe92bdb5
--- /dev/null
+++ b/sys-devel/dwz/dwz-0.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dwz/dwz-0.9.ebuild,v 1.1 2013/03/04 16:40:18 dev-zero Exp $
+
+EAPI=5
+
+DESCRIPTION="DWARF optimization and duplicate removal tool"
+HOMEPAGE="http://sourceware.org/git/?p=dwz.git;a=summary"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/elfutils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/d' \
+ Makefile || die "sed failed"
+}
diff --git a/sys-devel/dwz/metadata.xml b/sys-devel/dwz/metadata.xml
new file mode 100644
index 000000000000..ff3a66e3fcda
--- /dev/null
+++ b/sys-devel/dwz/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <longdescription>
+ The dwz package contains a program that attempts to optimize DWARF
+ debugging information contained in ELF shared libraries and ELF executables
+ for size, by replacing DWARF information representation with equivalent
+ smaller representation where possible and by reducing the amount of
+ duplication using techniques from DWARF standard appendix E - creating
+ DW_TAG_partial_unit compilation units (CUs) for duplicated information
+ and using DW_TAG_imported_unit to import it into each CU that needs it.
+ </longdescription>
+</pkgmetadata>