summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-14 17:42:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-14 17:42:00 +0000
commit96d3d07403c3027672918e8ca2e6c25637e69e8d (patch)
tree82ec3ccfb4c1b337f3d56a01d30c89aa8832e155 /sys-devel
parentStable on x86 per security bug #92393 (diff)
downloadgentoo-2-96d3d07403c3027672918e8ca2e6c25637e69e8d.tar.gz
gentoo-2-96d3d07403c3027672918e8ca2e6c25637e69e8d.tar.bz2
gentoo-2-96d3d07403c3027672918e8ca2e6c25637e69e8d.zip
use gawk, not awk #92582
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf-wrapper/files/ac-wrapper-1.sh90
-rw-r--r--sys-devel/autoconf-wrapper/files/ac-wrapper-2.sh4
-rw-r--r--sys-devel/automake-wrapper/files/am-wrapper-1.sh4
3 files changed, 4 insertions, 94 deletions
diff --git a/sys-devel/autoconf-wrapper/files/ac-wrapper-1.sh b/sys-devel/autoconf-wrapper/files/ac-wrapper-1.sh
deleted file mode 100644
index dca23bcbb92b..000000000000
--- a/sys-devel/autoconf-wrapper/files/ac-wrapper-1.sh
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/files/ac-wrapper-1.sh,v 1.2 2004/12/05 09:06:57 vapier Exp $
-
-# Based on the ac-wrapper.pl script provided by MandrakeSoft
-# Rewritten in bash by Gregorio Guidi
-#
-# Executes the correct autoconf version.
-#
-# - defaults to latest version (2.5x)
-# - runs autoconf 2.13 only if:
-# - envvar WANT_AUTOCONF is set to `2.1'
-# -or-
-# - `configure' is already present and was generated by autoconf 2.13
-
-if [ "${0##*/}" = "ac-wrapper.sh" ] ; then
- echo "Don't call this script directly" >&2
- exit 1
-fi
-
-if [ "${WANT_AUTOCONF}" = "2.1" -a "${0##*/}" = "autom4te" ] ; then
- echo "ac-wrapper: Autoconf 2.13 doesn't contain autom4te." >&2
- echo " Either unset WANT_AUTOCONF or don't execute anything" >&2
- echo " that would use autom4te." >&2
- exit 1
-fi
-
-binary_new="${0}-2.59"
-binary_old="${0}-2.13"
-binary="${binary_new}"
-
-#
-# autodetect routine
-#
-if [ "${WANT_AUTOCONF}" != "2.5" ] ; then
- if [ "${WANT_AUTOCONF}" = "2.1" ] ; then
- if [ ! -f "configure.ac" ] ; then
- binary="${binary_old}"
- else
- echo "ac-wrapper: Since configure.ac is present, aclocal always use" >&2
- echo " autoconf 2.59, which conflicts with your choice and" >&2
- echo " causes error. You have two options:" >&2
- echo " 1. Try execute command again after removing configure.ac" >&2
- echo " 2. Don't set WANT_AUTOCONF" >&2
- exit 1
- fi
- else
- if [ -r "configure" ] ; then
- confversion=$(awk \
- '{
- if (match($0,
- "^# Generated (by (GNU )?Autoconf|automatically using autoconf version) ([0-9].[0-9])",
- res))
- { print res[3]; exit }
- }' configure)
- fi
- if [ "${confversion}" = "2.1" -a ! -f "configure.ac" ] ; then
- binary="${binary_old}"
- fi
- fi
-fi
-
-if [ "${WANT_ACWRAPPER_DEBUG}" ] ; then
- if [ -n "${WANT_AUTOCONF}" ] ; then
- echo "ac-wrapper: DEBUG: WANT_AUTOCONF is set to ${WANT_AUTOCONF}" >&2
- fi
- echo "ac-wrapper: DEBUG: will execute <$binary>" >&2
-fi
-
-#
-# for further consistency
-#
-if [ "$binary" = "$binary_new" ] ; then
- export WANT_AUTOCONF="2.5"
-elif [ "$binary" = "$binary_old" ] ; then
- export WANT_AUTOCONF="2.1"
-fi
-
-if [ ! -x "$binary" ] ; then
- # this shouldn't happen
- echo "ac-wrapper: $binary is missing or not executable." >&2
- echo " Please try emerging the correct version of autoconf." >&2
- exit 1
-fi
-
-exec "$binary" "$@"
-
-echo "ac-wrapper: was unable to exec $binary !?" >&2
-exit 1
diff --git a/sys-devel/autoconf-wrapper/files/ac-wrapper-2.sh b/sys-devel/autoconf-wrapper/files/ac-wrapper-2.sh
index 97f559dfc39b..b85fade497bf 100644
--- a/sys-devel/autoconf-wrapper/files/ac-wrapper-2.sh
+++ b/sys-devel/autoconf-wrapper/files/ac-wrapper-2.sh
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/files/ac-wrapper-2.sh,v 1.1 2004/12/06 04:29:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/files/ac-wrapper-2.sh,v 1.2 2005/05/14 17:40:25 vapier Exp $
# Based on the ac-wrapper.pl script provided by MandrakeSoft
# Rewritten in bash by Gregorio Guidi
@@ -51,7 +51,7 @@ if [ "${WANT_AUTOCONF}" != "2.5" ] ; then
1.[7-9]) ;;
*)
if [ -r "configure" ] ; then
- confversion=$(awk \
+ confversion=$(gawk \
'{
if (match($0,
"^# Generated (by (GNU )?Autoconf|automatically using autoconf version) ([0-9].[0-9])",
diff --git a/sys-devel/automake-wrapper/files/am-wrapper-1.sh b/sys-devel/automake-wrapper/files/am-wrapper-1.sh
index 54935e0f7682..b21e0e0a2547 100644
--- a/sys-devel/automake-wrapper/files/am-wrapper-1.sh
+++ b/sys-devel/automake-wrapper/files/am-wrapper-1.sh
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/files/am-wrapper-1.sh,v 1.3 2004/11/15 00:57:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/files/am-wrapper-1.sh,v 1.4 2005/05/14 17:42:00 vapier Exp $
# Based on the am-wrapper.pl script provided by MandrakeSoft
# Rewritten in bash by Gregorio Guidi
@@ -71,7 +71,7 @@ done
do_awk() {
local file=$1 ; shift
local arg=$1 ; shift
- echo $(awk "{ if (match(\$0, \"$*\", res)) { print res[${arg}]; exit } }" ${file})
+ echo $(gawk "{ if (match(\$0, \"$*\", res)) { print res[${arg}]; exit } }" ${file})
}
#